USB passthrough in VirtualBox not working.

I am using a USB passhthrough of from Windows 7 as host til Ubuntu as guest in VirtualBox. This has been working fine until suddenly today when issuing fdisk -l in the Ubuntu guest I no longer see /dev/sdc listed. I can map the USB drive to the VM in VirtualBox, and the USB is visible in windows until I do so (the partitions on it are not visible any more on the host after VisualBox takes over), I just can't see the device in the Ubuntu guest anymore(/dev/sdX). Any suggestions?
LVL 2
itniflAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
Reinstall the guest additions within Ubuntu, or if you originally installed them directly through the distro's repos, run a

sudo apt-get update
sudo apt-get dist-upgrade

so they get updated along with the rest of Ubuntu.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
itniflAuthor Commented:
Sorry, I tried it all and it did not work. I also restarted the VirtualBox install and chose repair, then I reinstalled the Virtual Box Extension Pack on the host and rebooted the host after all was done. Same problem still.
0
rindiCommented:
Did you download and install the newest extension pack that corresponds with your version of VBox?

After you downloaded the extension pack did you also install the new version within your VM?

VBox updates also need new extension packs. New Packs have to manually installed within your VM if you originally installed them via the iso inside your VM. Ubuntu kernel updates, if you didn't install the addons via the ubuntu repositories, will be without VBox support, so after each such update you also need to re-install the addons within ubuntu manually.

Besides that, what version of VBox are you using? If it is the new version 5, I've had issues with it and for the moment returned to Version 4.3. Besides that, I don't know if the Ubuntu repos properly support version 5 yet.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

itniflAuthor Commented:
These are the versions:
VirtualBox-5.0.2-102096-Win.exe
Oracle_VM_VirtualBox_Extension_Pack-5.0.2-102096.vbox-extpack

I mounted the Virtual Box Guest Additions iso that came with the installation and installed that after all this was done.
0
rindiCommented:
Then you have to reinstall those whenever your kernel gets updated. Also, as I mentioned above, I've had issues with VBox 5. I'd go back to VBox 4.3 until those issues are resolved. Problems I had for example were my complete network going down as VBox caused IP conflicts after some time of use.
0
itniflAuthor Commented:
I will try out 4.3
0
itniflAuthor Commented:
Didn't look like version 4.3 experienced any less of this USB problem. I am starting to believe that it some configuration in the host system that makes the problem. I downgraded VirtualBox, the Extension Pack and Virtual Box Additions. I have also tried creating a new VM(under the previous 5.03 version I used).

I have now upgraded back to version 5.03.
This is how the USB setup on the VM looks.
This is how the USB setup on the VM looks.
When hovering over the USB sign it says that no USB devices are attached.
When hovering over the USB sign it says that no USB devices are attached.
When I try to attach the USB device by selecting it in the menu I get when pressclicking ng the USB sign I get this error.
When I try to attach the USB device by selecting it in the menu I get when pressclicking ng the USB sign I get this error.
If I stop the VM, remove the filter in the USB setup shown in the first picture, and then later after booting the VM try to attach the USB device while the VM is running I get no error message. But no usb device shows itself in the VM. I then try to attach the USB device again and the same thing error as in picture 3 above happens again:

Failed to attach the USB device General USB Flash Disk [1100] to the virtual machine AutomationVM1.

USB device 'General USB Flash Disk' with UUID {214bd411-016a-4a0a-b207-16d0a829ad5c} is busy with a previous request. Please try again later.



USB device 'General USB Flash Disk' with UUID {214bd411-016a-4a0a-b207-16d0a829ad5c} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDeviceWrap
Interface: IHostUSBDevice {c19073dd-cc7b-431b-98b2-951fda8eab89}
Callee: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}
0
rindiCommented:
Try changing from USB 3 to 2.
0
itniflAuthor Commented:
After changing to 2.0, the first time I connect the USB, no error is stated. When hovering over the USB sign it says no USB device is connected. When using fdisk -l inside the VM, no new drive appears. I then reboot the VM, and the result is the same. I then try to select the USB drive again from the VirtualBox menu and get the same error as shown in my previous post. The drive is no longer visible in Windows explorer on the host, so I assume it is being handled by VirtualBox. Looks like VirtualBox takes over, then things just kind of hang and the drive is jus marked as busy. The result is same for both VirtualBox 4.3 and 5.03.
0
itniflAuthor Commented:
I gave up and started using VMware Workstation. USB passthrough works fine there. Looks like to me by the information found on Google that VrtualBox has had problems with various USB drivers on the host computer for a long time. Since at least the 4.3 version.

One popular article I found claims that uninstall of various usb drivers and the deleting usb related registry keys, then reinstall of those drivers should fix the proplem. I did try and ended up with a system where nothing usb related worked and had to fix that. Maybe I made a mistake and should try again, but I think I rather give this up.

Giving points for all contributions.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.