"Invalid" SSL certificate issues from home connection

I intermittently have this problem from my home connection.  I had this issue before on my older laptop, I am using a brand new laptop now and having the same issue, so this isn't some kind of malware on my system.

I recently switched my home router from using OpenDNS name servers to using Google's name servers, thinking maybe that might help or at least to see if that was related, but still having the problem.

Below is an example of what happens. I try to access a common site in HTTPS (in this case, my Outlook/office365 account), but this happens with other sites and often even when accessing Google.com of Facebook.

It will give me an error that the SSL cert doesn't match, and the cert that the connection is trying to use is often one that sounds like an ad network.  This time in the example below it's a symantec cert.

Just to mention - I don't run Symantec on my machine, I use ESET Nod32.

This is a real problem, and I don't understand why this is happening. It later clears up all by itself, but there doesn't seem to be anything I can do to bybass it (other than use FireFox as at least in some cases it lets me "accept" the suspect cert so I can get to where I needed to), but Chrome and IE just refuse to me me access the site that is having this problem at the time.


example


I have a U-Verse Internet connection, and my router is connected to a wifi router which I use for my entire entire (I only use the U-Verse router to access the Internet and then all traffic is sent to the Cisco/Linksys Wifi Router WRT160n, where I use both the wired and wireless for my entire network.
LVL 1
VasAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
It sounds like you used to have Norton Internet Security and it was not completely removed.  Try using the Norton Removal Tool (NRT) to see if it cleans up the problem.  Note the warnings when you use it.  https://support.norton.com/sp/en/us/home/current/solutions/kb20080710133834EN_EndUserProfile_en_us

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
VasAuthor Commented:
Thanks, the system did have McAfee pre-installed, which I immediately un-installed and then installed Eset.

I ran the remover.  Won't know for a while if this worked since it's intermittent but your solution makes sense thanks.
Dave BaldwinFixer of ProblemsCommented:
Thanks for the points.  Note that McAfee has it's own removal tool also that you might want to run.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SSL / HTTPS

From novice to tech pro — start learning today.