error loading SCO unix 5.0.5 in new install

I am getting an error trying to load SCO Unix 5.0.5 on a new hard drive
The error is  "addcore: configuration problem - memory segment 260424 - 256/s/n overlaps Segment 262080k-2156m/p  memory error loading kernel FD964)unix.text"
I get the same error using my boot floppy or CD.
can anybody help?
Thank you
dave2015Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mikelfritzCommented:
Put Bios in safe mode.

Also, It sounds like maybe your disk is too big for 5.0.5 to deal with.

http://www.tek-tips.com/viewthread.cfm?qid=719546

You can put in boot parameters to specify the disk size, but there is a limit.

There is also the possibility that the install is looking at the MBR for clues.

http://lists.celestial.com/pipermail/sco-misc/2004-March/000511.html

This option should be fine since it's a "blank" drive - some of these are not really blank though.
0
mikelfritzCommented:
Also - what hardware?  If it's too modern I doubt it will ever work with 5.0.5.
0
dave2015Author Commented:
The hardware is about 15 years old working currently with SCO 5.0.5 but our hard drive is giving badblock errors. so we bought another 4GB scsi hard drive to replace current drive.
I am now getting errors "invalid partion" on boot up of floppy or cd Is that referring to the new hard drive?
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

gheistCommented:
Looks like your SCO kernel (or boot driver) is limited to 256MB of RAM
0
mikelfritzCommented:
Try at the boot: prompt:

defbootstr mem=0k-639k,1m-64960k


Also:
http://www.experts-exchange.com/OS/Unix/Q_21637346.html
0
mikelfritzCommented:
after loading you would need:

SLS oss610b: E820 Memory Sizing Boot Patch

http://www.sco.com/support/ftplists/osr5list.html
0
dave2015Author Commented:
Sorry for the Delay in replying. The original computer just died and we replaced it with a Dell GX1 my old hard drive boots fine minus a few bad blocks. We are trying to replace the hard drive with the same Specs also 4gb We downloaded the driver from the internet for the SCSi card 2940uw we get as far entering our license number and code no error message but it dies at that point. starts to load and says please wait.
0
gheistCommented:
I can only suggest contacting xinuos.
0
mikelfritzCommented:
Have you tried at the boot prompt:

defbootstr mem=0k-639k,1m-64960k
0
gheistCommented:
(and setting date back to before Y2K)
0
dave2015Author Commented:
What does setting the date back do? I think we tried both way with the date in the Bios
I didn't try "defbootstr mem=0k-639k,1m-64960k ".
Does having a dos partition of 4gb on the drive have anything to do with my problem with the OS not loading.
I will not be able to try or do anything for at least another week.
0
mikelfritzCommented:
That bootstring is to get past the known memory issue.  Setting the date back can help with other issues but should not be needed.

After a good load you'd apply this to fix it for good:
http://www.sco.com/support/ftplists/osr5list.html
0
mikelfritzCommented:
See the first post on the disk not being truly blank.  Yes, this can affect you. SCO can read the MBR for disk geometry information instead of asking the disk itself (or it's controller).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dave2015Author Commented:
Took off the Dos partition and then it loaded with no problem
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.