asp.net upload to host issue: compile error when uploaded

I'm using VS2013 Premium with a complex "single page" web site project, written in vb.net.  I'm publishing to file system and uploading with FTP to a remote host.  I'm Just starting to test deployment.

The web site runs fine in the local development.

When I publish as "pre-compiled, single assembly", the application runs fine on the remote host.  I haven't tested all the functionality, however it does many major functions.   This also helped to identify a few compilation errors that I fixed.

However, when I publish the web site with no "pre-compile" settings, I get a compile error when I run the app on the remote host.

The compilation error detail is a lot of text that looks like this (in part):

"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\cbfe14e5\d79d23f0\App_Code.hrrdiq93.8.vb" "C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\cbfe14e5\d79d23f0\App_Code.hrrdiq93.122.vb" "C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\cbfe14e5\d79d23f0\App_Code.hrrdiq93.0.vb"

Open in new window


Questions:  
>  Is there a particular way to read and interpret the compilation errors to find out what the specific problem might be?
>  Is there a potential that the compilation error could be "hidden" in the "single assembly" version, and produce a functional error later?

Any help with this would be appreciated.

Thanks!
LVL 2
codequestAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kyle AbrahamsSenior .Net DeveloperCommented:
Are you publishing to the same place?

If so you need to delete the bin directory.

Essentially when you do the pre-compiled version everything gets put in the DLL, which is copied to the bin.

When you don't do the precompiled, everything gets compiled anyway (for efficiency reasons).  Those are then copied to the temporary folder that you see.  .Net doesn't know whether to use the pre-compiled dll version or the one that it just compiled, so it throws that error.
codequestAuthor Commented:
Thanks for the input; I can how see that could be the problem.  However, I'm not sure which been folder is in play here.  I am building to a local folder and using the "delete all existing files prior to publish" option.  On the host, I delete everything in wwwroot before uploading.  I just ran through the cycle again, manually deleting the local publish-to folder and verifying that the host wwwroot folder is empty.  

That leaves the bin folder in the development environment.   I thought I could not delete all that stuff because it has information from assemblies and such.  It only has dlls, xmls and refresh files related to needed packages.  The local publish-to folder, after publishing only has the package dlls (4 of them).  

So I'm not sure where a faulty bin entry could come into play.
Kyle AbrahamsSenior .Net DeveloperCommented:
The other thing you can do is delete the folders in

C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\

that appear in your error message.  Those files are created by the compile process and only one of them should be recreated as needed.
Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

codequestAuthor Commented:
Thanks for the input.  I tried that:  no joy.   I've contacted the hosting company to see if they will do anything about it from their side.
codequestAuthor Commented:
The hosting company identified that the error was caused by the site having 32-bit app pool instead of 64-bit app pool.  They changed the site to 64-bit app pool and when I re-published with a small web.config change to trigger a reset of the site, the compilation error 1 went away.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
codequestAuthor Commented:
The comment I added was a specific resolution to the problem.  The hosting company was Arvixe.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.