Can't Open USB Devices

I have a Lenovo T440 laptop with Windows 7 Pro that has developed an new problem. I can insert USB devices and they show up in Windows Explored but if I try to access the I get an error that says "D:/not accessible. Access is denied." I can install the same device in a different laptop, use the same user account and have no problem reading the drive. What could be causing this problem and how can I resolve it?

Thank you!

Robert
Robert EhingerIT specialistAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

noxchoGlobal Support CoordinatorCommented:
Hi Robert,

is the drive detected as having FAT32 or NTFS file system in Windows Disk Management? Do a right click on My Computer - Manage - Disk Management. See if the connected USB stick has a detected file system (NTFS or FAT32). If yes then your problem is in access rights. You need to take ownership of the drive.
If not - then the problem is in file system of these drives. Connect the drive to a PC where you can work with it - and check the partitions on the drive with CHKDSK x:/f via command line where X: is the drive letter of a USB drive.

There is also a third possible reason of this problem - the USB interface of your "problem" machine does not give enough power to the drive. Thus you need to try connecting the drive via powered USB hub.
0
systechadminConsultantCommented:
turn off the UAC and use windows explorer to explore files and then try to open the flash drive
0
Robert EhingerIT specialistAuthor Commented:
All my flash drives are seen as FAT32 but if I try to take ownership I get the access denied message.
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

Robert EhingerIT specialistAuthor Commented:
Turning off UAC did not help. Same problem.
0
Robert EhingerIT specialistAuthor Commented:
I do have one flash drive that is NTFS but I have the same issues with it.
0
noxchoGlobal Support CoordinatorCommented:
Then you need to check with a powered USB hub. Have you tried them on all USB connectors?
As a test you can uninstall USB interface via Device Manager - then restart and let the driver install again. After that check if the problem is gone.
0
Robert EhingerIT specialistAuthor Commented:
I have the same issue using a powered USB hard drive enclosure. I get the same error when I try to access the data but I can run hard drive diagnostics on it. This is a new problem that just started this morning and that is why I don't understand what could have possibly happened to cause this.
0
noxchoGlobal Support CoordinatorCommented:
You can roll back the system to restore point with hope that it will fix the problem.
Try to remove USB devices from Device Manager (uninstall USB concentrator), reboot and let it teinstall.
Amother idea which came to my mind - will the USB drives work if the machine is booted from a WinPE CD or from Linux distro?
0
nobusCommented:
it can be caused by manufacturer software , see the solution for HP here :  It was the pre-installed "HP Device Manager" causing the denied access
http://h30434.www3.hp.com/t5/Notebook-Operating-Systems-and-Software/Access-Denied-on-USB-drives/td-p/3662944
if you have similar software - uninstall it - or call lenovo in !
0
Robert EhingerIT specialistAuthor Commented:
OK, here is what I have tried over the past week or so -  I needed to make a bootable USB stick so I used diskpart to clean and format the USB drive and I had no problem doing that. I also had no problem extracting files to the drive. But once I removed the drive and reinstalled it I got the drive not accessible message.
I tried changing the permissions (because I thought being inaccessible could be a rights issue) but when I try changing permissions or changing the owner I get an "access denied" message.
The drive appears in Computer management and the size is correct but I can't do anything with it.
Any more suggestions?
0
dbruntonCommented:
What is it like on other machines?

Also look at Rufus https://rufus.akeo.ie/ to set up your USB sticks.
0
nobusCommented:
try safely remove to acces the drives http://safelyremove.com/?pid=1

try also this :
right click on the START icon, select explore all users, navigate to your USB stick in the left column, and you should be able to open it.
 alternatively go to RUN type D: and press enter.
0
Robert EhingerIT specialistAuthor Commented:
All of these USB sticks work just fine in other machines and they all worked in this one until recently. I did not use Rufus because I am not having any problem creating a bootable USB device and I do not want to format any of these flash drives.
If I right click on Start I do not have the "explore all users" option and if go to RUN type D: and press enter, I still get the drive not accessible error. If  I try to run the safely remove app I get an endpoint security personal policy alert - Data Protection Alert - "PSG protected a file from being changed"
0
nobusCommented:
it seems you heve the endpoint security installed- can you disable it momentarily for testing?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Robert EhingerIT specialistAuthor Commented:
That did the trick. I think there is an updated version that will fix the problem.
0
nobusCommented:
tx for feedback - and i'm happy to be able to help
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Laptops Notebooks

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.