Laptop keyboard problem, some letters now typing as number numbers

Acer Aspire AS3810TZ-414G25n, Windows 10
I plugged an external USB Microsoft full size keyboard into the above laptop. Now, whether it's connected or not, some of the letters appear as numbers on screen. Here's what I get when I type all 26 letters in the order they are on the standard layout keyboard:

First with caps lock off:
qwerty456*
asdfgh123
zxcvbn0

Then with caps lock on:
QWERTY*      (last 3 get blank)
ASDFGH        (last 3 get blank)
ZXCVBN        (last 1 blank)

The 0 key types as a / and the / types as a +
Martin CampbellAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

William FulksSystems Analyst & WebmasterCommented:
Your numlock key is pressed. It was probably turned on when you plugged in the keyboard.
1
arnoldCommented:
Usually on the keyboard, there is a function key and a num lock that have to be in combination to turn off as John pointed out.

If you look at the keys usually jkl are 456 the three above and three ... The numbers usually in different color that matches the fN key often between left control and start, and the num lock in a similar color on the right side of the keyboard. It might be part of the

[num]


It could have been mistakenly activated, instead of hittin control home/end the Fn key was depressed.........
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Joe Winograd, Fellow&MVEDeveloperCommented:
Hi Martin,
Here's an EE question that I participated in a few months ago discussing the same issue:
http://www.experts-exchange.com//Hardware/Laptops_Notebooks/Q_28684482.html

I think the answers in there will help you. Regards, Joe
0
ON-DEMAND: 10 Easy Ways to Lose a Password

Learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees in this on-demand webinar. We cover the importance of multi-factor authentication and how these solutions can better protect your business!

Martin CampbellAuthor Commented:
In my case JKL gets 456. The first thing I did when I discovered the problem was to find and press the NumLk key. Unfortunately this didn't fix the problem. But your mention of the Fn key put me on the right track. Fn+NumLk toggles the number keys on and off. The evidence suggested that attaching an external keyboard was what caused the problem but I've now experimented with this and found it doesn't. It must have been just a coincidence that accidentally turning on the numbers happened about the same time as attaching the external keyboard.
1
Martin CampbellAuthor Commented:
Sorry, I got mixed up. In my case JKL gets 123.
0
arnoldCommented:
Attaching tge external keyboard that has a numbers pad entices the user to hit the hum locks to use the numbers pad on the right, most likely not noticing/remembering to turn off num locks before detaching the external keyboard.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Peripherals

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.