Unable to Configure send connector in exchange 2013

Hi I have just installed Exchange 2013 using CU9 on a windows 2012 R2 server running as a DC (all fresh installs).

Everything seems fine,  but when I log in to admin center mail flow to create a new send connector I get all the way through and click ok and it just sticks and nothing happens. Have tried this a few times now same issue.

Could anyone please help?

Thank you.
daly29Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Amit KumarCommented:
Try using any other browser, clear or cache of browser. if you are using IE then try adding in Compatibility view.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
daly29Author Commented:
Thank you so Much appreciate it worked fine
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.