Ricoh 5501 - can ping, but can't access web interface or print

Got a weird one for any Ricoh/Printer gurus out there:

1.  We're talking about a Ricoh 5501 - in an office with several other Ricoh printers - some 5501's, some other models.
2.  This particular Ricoh 5501 was humming along fine until today...office manager reports she can no longer print to or scan from it.  Her assistant in the next office over, however, can print and scan fine.  I am in yet a different part of the building - I cannot print or scan to it.
3.  I can ping the printer just fine.
4.  When I attempt to connect to the printer via the web interface, I'm seeing something bizarre - a plain white page with the words "it works!" on it (see attached image).  Never seen or heard of this before.  And the assistant who can print successfully - when I try to connect to the web interface of the printer using her computer, she sees the same "it works!" message.
5.  On my laptop and on the office manager's computer, the printer shows as offline....at the printer itself, it says it is online.
6.  Additional troubleshooting on my laptop - uninstalled/reinstalled the printer driver.  No joy.
7.  Tried setting up direct IP connection to the printer, but the printer TCP/IP wizard fails with "Additional port information required.  The device could not be identified."
8.  Power-cycled the printer several times - no joy.  
9.  There is another Ricoh printer 5501 next to the problem child, and it is working fine for everyone - did a tracert to both the problem printer and the good printer to see if there might be some weird firewall or VLAN stuff going on, but got to both printers in one hop immediately.
10. Compared network settings of both the problem child and the working printer - identical except for IP address.  

I'm officially stumped - any suggestions are much appreciated.

Dave
printer_weirdity.JPG
djfox1963Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

masnrockCommented:
Who services the machine? I would bet there are some missing firmware updates. On the PCs with issues, have you cleared and restarted the print spools? Also, have you checked the network for any potential IP address conflicts? That would rank very high on the list of what may cause the issues you're experiencing.
Mal OsborneAlpha GeekCommented:
My guess here is a rouge device on the network with the same IP as the printer, and some sort of web server.  The message you have is the default for an unconfigured Apache server.

Does ARP-A show the wrong MAC address, when run on your machine?
djfox1963Author Commented:
Masnrock & Malmensa, thanks for the suggestions.  I think both of you have good ideas - 1) the printer probably needs a firmware updgrade, and 2) I think the Apache Web Server "it works" welcome message is probably coming from the printer itself due to the web interface on it being farkled - possibly because of a needed firmware upgrade or an upgrade that went bad.  

I wasn't able to run ARP commands to verify the Mac address of the printer because I'm not on the same subnet as the printer, but the IP address on the printer is static...any other device that tried to use the same IP address would get an IP conflict error message.

I've called Ricoh and asked them to come out and check the printer...I'm reasonably certain this will turn out to be a firmware issue.   Thanks again to both responders for the suggestions!
PMI ACP® Project Management

Prepare for the PMI Agile Certified Practitioner (PMI-ACP)® exam, which formally recognizes your knowledge of agile principles and your skill with agile techniques.

masnrockCommented:
Disconnect the Ricoh and ping the IP just to be sure. Assuming a conflict, it could be one of a number of devices, not just a PC.

Let us know what happens regardless.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jagnacCommented:
Try doing a "telnet <ipaddressofprinter 515" or "telnet <ipaddressofprinter 9100" from a non working PC and a working PC
This may give more info on blocked ports and ACL
You should also try using https://ipaddressofprinter from IE/Chrome to printer web page instead of http://ipaddressofprinter
djfox1963Author Commented:
Masnrock, you are a genius.  I was gob-smacked to see that after I shutdown the printer, I could still ping the IP.  Turns out the IP on the printer was never reserved as it should have been, and another device grabbed the IP from DHCP.  We reserved that IP for the printer and all is well again.

Thanks to all for the suggestions!
masnrockCommented:
I would recommend changing your DHCP scope, so that any addresses you plan to have reservations for do not fall in that range. So even if for some reason the reservation for deleted, no device can take that address.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.