Unable to connect to remote server using SMB over VPN

Hi,

I'm Unable to connect to the Remote server via SMB over the VPN from a Mac. Able to ping the device, and have tried connecting using the host-name and the internal IP address.
No blocked traffic showing on the firewall

Regards
Hasan
LVL 2
Technical InformationAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kevinhsiehCommented:
What happens when you try to telnet to the server on port 445? If you can connect then the network is working properly. If you can't then you have a network or firewall problem.
0
Mark BullockQA Engineer IIICommented:
The command would be: telnet yourserver.yourdomain.com 445

If you don't have telnet installed, here are the instructions.
https://technet.microsoft.com/en-us/library/Cc771275(v=WS.10).aspx#bkmk_installLHS
0
Technical InformationAuthor Commented:
amateur question but would I have to be in the VPN or can I do it from where I am? I'm not in the same building
0
Hey MSSPs! What's your total cost of ownership?

WEBINAR: Managed security service providers often deploy & manage products from a variety of solution vendors. But is this really the best approach when it comes to saving time AND money? Join us on Aug. 15th to learn how you can improve your total cost of ownership today!

kevinhsiehCommented:
You need from the Mac over the VPN.
1
Technical InformationAuthor Commented:
I am able to connect to the share from a spare Mac on the users network. It seems to be an issue local to this Mac. I have also just updated to Yosemite and still no luck
0
Jeff GloverSr. Systems AdministratorCommented:
If you can connect from a MAC on the local network then it is probably something to do with your VPN. Can you ping the internal address of the file share server from your MAC when it is connected via VPN?
0
Technical InformationAuthor Commented:
The issue seemed to be the users home network being on the same IP address range as the DC at his office.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kevinhsiehCommented:
I believe that you are always going to have unreliable operation if the remote network overlaps with the local subnet. You should change the addressing one one of the subnets.
1
Technical InformationAuthor Commented:
After further testing with wireshark packet capture, there was no difference in the traffic between when share access works and when it doesn't.

After further testing it seems the issue is being caused by users local network being on the same IP address range as the DC server IP address range.

After disconnecting and re-connecintg the VPN a few time connection to the SMB share seems to work again
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.