Nk2 / Autocomplete - Any way to tell Outlook to NOT save "EXCH" type addresses and only "SMTP" addresses

Have a client with mostly Office 2007 (won't upgrade to 10 or 13 yet).  So, still using NK2 files.  I'm pretty sure that somewhere/someone in the organization has old/invalid Exchange addresses in their NK2 for a couple users.  That "someone" (or multiple "someones") with the old/invalid Exchange addresses appears to be polluting other user NK2s when they send out emails.  These users with the "polluted" NK2 file are receiving the following bounce error even after multiple attempts at deleting the bad entries:  550 5.1.1 RESOLVER.ADR.ExRecipNotFound  
The organization is large enough that I can't go to each user(s) and NK2 file to find and "x" (delete) the entry when found.  Turning off the NK2 ("Autocomplete") function entirely would not be a popular option.  

So, my question boils down to:  Is there a way to tell Outlook to store ONLY external smtp addresses in the NK2 and NOT internal exchange addresses?

A secondary question is:  Is this even an NK2 issue or could these invalid Exchange addresses be coming from something like "Suggested Contacts?"

Thanks in advance.
LVL 1
jgutmanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Trent SmithCommented:
I don't know of any way to do what you are looking for.  These invalid Exchange addresses had to be entered if they were put into the auto complete list.  I would suggest either teaching the users how to remove them or reset all the auto complete lists and then let them start over.  Sorry not a whole lot of options on this one.
0
AmitIT ArchitectCommented:
You can use login script to delete nk2 file for users. Read this
http://arstechnica.com/civis/viewtopic.php?f=17&t=455895

Test before you do mass change.
0
Will SzymkowskiSenior Solution ArchitectCommented:
There is no way to accomplish this. You can only turn it on or off unfortuneately. Also see the TechNet Forum post.
https://social.technet.microsoft.com/Forums/exchange/en-US/37fdcc86-150d-4123-be66-9fde9dba317c/disable-auto-complete-for-external-email-addresses

Will.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jgutmanAuthor Commented:
Yeah - I kinda had a feeling that was going to be the answer.  Thanks for weighing in.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.