Unable to delete a an Organization Unit in Group Policy Management - Windows 2012 Server

I am trying to delete an organization group with the Group Policy Management MMC.
I Right Click, Select Delete, Informs me "Do you want to delete this organization Unit ? This will also delete all child object under this organization unit"  - I am a member of the DOmain admin group by the way.
I click on OK and I get  "Group Policy Management"  Access denied

My user is a member of Domain Admins so I should be fine I woudl have thought. Just tested by deleting a the container Group Policy assigned to Org Unit. That was allowed but not the container itself ?
ccfcfcAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Peter HutchisonSenior Network Systems SpecialistCommented:
The OU may be protected from deletion by a tick box on the OU properties to prevent accidental deletion. Once that is un-ticked you can delete it.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Will SzymkowskiSenior Solution ArchitectCommented:
As Peter stated that Accidential deletion is probably the most common reason here. However i would be checking the Permissions on this OU to make sure that Domain Admin do have permission (maybe the inheritance got removed).

If permissions are correct then most likely accidential deletion.

Will.
ccfcfcAuthor Commented:
I had to turn on "Advanced Features" then I was allowed to TURN OFF this setting.

Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.