Server 2012 R2 - Black Screen of Death on login.

I have a server running Server 2012 R2 (with GUI) with all the updates. This server is not in production yet, so it's at the stage where I can reformat without too much stress if it comes to that, but I'm wondering if anyone has an idea on what to do with this.

Server was fine while I had it on my workbench doing all the prep work to it (load OS, install drivers, install HP management software, install Windows Updates, etc). Rebooted several times with no issues. This is also going to be a domain controller, so I went ahead and installed Active Directory services from add roles/features in Server Manager (although it is not a DC yet, nor has it even been joined to the domain yet). When I last shut this server down while it was on my workbench, it was happy as could be.

So I took the server to my client's office. Plan was to connect it to the network and do things like promote it to a DC and slowly start migrating file shares/apps and such to it over the course of a week (it will be replacing an older server that's still running Server 2003). Connected it to the network and fired it up. Get to the login screen and press ctrl+alt+del. Enter password for local admin account. At this point, I get a black background screen with a mouse cursor, and that's pretty much it. I can press ctrl+alt+del and open task manager, but that's about all I can do.

Note: I have read that this problem is something that people have experienced with server 2012 when trying to RDP into it, but I'm physically standing in front of the server, at the console. So RDP is not involved here.

Some things I've already tried (and a few other notes):

- Boot in safe mode with networking. The only difference I've found is that command line works in safe mode with networking. So in normal mode, I can fire up Task Manager, but running cmd.exe (from the "new task" option in Task Manager) does nothing. If I'm booted in safe mode with networking, I can actually fire up a command prompt from here.

- Create a second user account from command prompt using the net user commands and try logging on with that. I created the account successfully, but I get the same black screen after logging in as that user.

- Explorer.exe does not appear to be running. Attempting to run it from task manager (New Task -> Explorer.exe) does nothing.

- Tried to run sfc.exe. Get "Windows Resource Protection could not start the repair service"

- Server responds to some things while it's in this state (I can browse to administrative shares on it from across the network and ping it).  

So....again, this is a pretty fresh install of Server 2012. It's an HP ProLiant DL380 G7 server. Aside from installing HP drivers/management stuff (ilo configuration/system management homepage), Windows Updates, and a few things from Add Roles/Features, there's nothing else on this server.
jhighwindAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hypercat (Deb)Commented:
Have you tried launching Server Manager from "New task" in Task Manager?  Just try typing "servermanager.exe" and see if it launches.  You should also be able to launch other admin tools like eventvwer.exe or services.exe, which would at least let you look into what's going on and troubleshoot what's causing your black screen.
0
jhighwindAuthor Commented:
Doesn't appear to be working. I enter servermanager.exe, and nothing happens.

The processes tab shows that ServerManagerLauncher.exe is running. I tried killing that with End Process and trying to kick it off again, but no change.
0
Hypercat (Deb)Commented:
Hmmm - did you try any of the other admin tools?  In Task Manager, are you seeing any activity - i.e., what processes are running and what is the CPU and memory usage?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

jhighwindAuthor Commented:
Yeah, I can see a whole list of processes. Task Manager appears to function pretty normally, aside from the fact that I'm not getting responses on trying to run some new tasks (cmd.exe from safe mode appears to be about the only thing I can do). Looks like I can kill most of the currently running processes with no issue.

I can also look at the services tab and see what services are running. It allows me to start/stop some of them from there, although trying to click the "Open Services" link at the bottom just gives me a "Microsoft Management Console has stopped working" error.

Looks like System Idle Process is at 99%, and memory usage is at 1.1/64GB (2%). So it doesn't appear that I'm dealing with any kind of resource hog here.
0
Hypercat (Deb)Commented:
Is this a virtual server?  Take a look at this community post from Spiceworks.  Lots of posts and suggestions - maybe something will be helpful.

https://community.spiceworks.com/topic/406717-server-2012-black-screen-on-login
0
Hypercat (Deb)Commented:
Also, this is old, but if you didn't fully patch the server already, it could be a factor:

https://support.microsoft.com/en-us/kb/2897632
0
jhighwindAuthor Commented:
Not a virtual server.

I believe it's fully patched. While I had it on my workbench and was getting the server prepped, I was repeatedly running Windows Update + installing what it found until it told me no further updates were available upon a manual check.

I'll check out that patch. Although...if I'm assuming that it's not installed for some reason, getting it to actually install in the server's current state may be tricky unless I can somehow run it from a command prompt in safe mode.

I've left the client's site for now, but the server does have an ilo card that is working perfectly fine, so I may remotely connect and poke around in it some from home this evening.
0
jhighwindAuthor Commented:
So...another small update, but unfortunately, it's just another "I tried it and it didn't work" thing.

Booted with F8 to the "Repair your computer" option. Launched command prompt from there and ran sfc /scannow (which doesn't work when I try to run it from safemode). Said it found corrupt files and fixed them all. Rebooted, but there doesn't appear to be any difference. Just thought that was worth mentioning.
0
jhighwindAuthor Commented:
Actually....yeah, I think at this point I'm just going to call it a day and just reformat this machine tomorrow. There are so many commands that aren't even working. Pretty much everything I've found online that says to try this or that, I try it, and get some error message for why that command doesn't work. It's like....try this command. Ok, that command doesn't work. Try this one to fix it. That one doesn't work. Try this one to fix it. And so on.

At least the server pulled this _before_ I got anything critical on it. At this point, a reformat isn't going to kill me. At this point, I don't think I'd feel comfortable proceeding with migrating the important data/applications from the old server to this one, even if I did somehow manage to Band-Aid this server and get things proper again. I don't think there's any kind of hardware issue going on because all the HP diagnostics are passing. Feels to me like the OS is just hosed. Like "Vista home user machine that's eaten up with malware" hosed.

I just think it's really bizarre that this machine worked fine (over repeated reboots during things like update installs) on my workbench, but it started this once I got it to my client's site and connected it to the network.

My guess at this point is that maybe it installed some Windows Updates on the final shutdown from my workbench, and something went horribly wrong with one of them. But yeah, I think I'm at the point where I could spend days chasing my tail on this or just reformat / reload Windows in an hour and be done with it (and hope this was just some fluke that's not going to happen again).
0
jhighwindAuthor Commented:
Just a final update: I went ahead and did the reformat/reinstall remotely (had access to Server 2012 install media, and ilo cards are awesome).

So far, things appear to be fine.

@hypercat: thanks for your time and comments. I honestly can't explain what happened to that server that crippled it so badly on a fresh install, but I figured at this point it would just be easier to wipe it out and start over. I'm in the process of doing things like driver installs and Windows Updates and such, but we're looking good so far. Will report back here if any weirdness happens.
0
Hypercat (Deb)Commented:
I'm in agreement - I was thinking I should have said that in my last post.  Sometimes it's hard to "cut the cord" but throwing more time into problems like this can just get you going around in circles.  Glad you got it sorted out. One thing I would recommend is that you wait until you're sure the server is successfully joined to the existing domain before you add the AD Domain Services role.  I can't imagine why that would cause your issue, but if I read your OP correctly, it's the last thing you did before you shut down and brought the machine onsite.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jhighwindAuthor Commented:
So....here's an interesting plot twist, if anyone's still reading this. I have another server on my workbench, that is completely identical to the server in my OP (same hardware, same OS, same configuration). It just started the exact same thing at some point over the weekend. You can press ctrl+alt+del and enter your password, and you get the same black screen of death. It was perfectly fine (and had been for days) until that last reboot.

I'm thinking maybe you're right about how I should join the domain _before_ adding DS Services role. It's about the only thing I've done to these servers yet, aside from installing drivers and Windows Updates. I've been going ahead and adding that role while I have the servers on my workbench in an attempt to save a little time + a reboot while I'm on site with the client, but maybe that's screwing something up. I am going through quite a few of these because I have a lot of clients who are still pushing to decommission their old Server 2003 machines.

Another side note: I am running a third-party program on these servers called Classic Shell (basically a small program that changes the interface to look more like Windows 7/Server 2008 with a start menu). That being said...I don't think it's the culprit here. If it were, I can imagine that maybe in the WORST case, it'd cause some problems with Windows Explorer. In this case, Windows Explorer isn't the only thing broken. I have all kinds of Windows services that are failing to start and what feels like a completely hosed OS. I could probably live without Classic Shell, but I really don't feel like that's the problem.

The other server on my workbench hasn't been sold to anyone yet (it's basically just one that I'm preparing/gearing up), so it's not critical at all and won't be a headache to reformat. Just thought that might be worth mentioning here. When I reformat it, I'm going to hold off on adding AD Directory services until I get it on site somewhere and get it joined to a domain first.

The general steps I usually go through when I get one of these servers:

- Configure RAID. Usually a RAID1+0 boot volume and a RAID5 storage volume.
- Install OS (Server 2012 Standard R2).
- Install drivers downloaded from HP's site.
- Install Classic Shell.
- Install HP system management stuff (ilo config, system management homepage, etc).
- Install roles/features (SNMP service because it's required for HP SMH, Active Directory Domain Services, DNS/DHCP server services). I don't actually configure any of these services (aside from SNMP) at this point, but just add them in roles/features.

- Install Windows Updates. I usually do a manual check for updates, install everything it can find, reboot, check again, and repeat process until it no longer finds anything.

Before I actually get them on site to a client, that's about it. But yeah, I'm going to start leaving out AD Directory services until after I've joined these to client domains. For the most part, these servers are getting put in place at small businesses and aren't doing anything particularly fancy. 90% of the time, they're acting as simple file servers/domain controllers on small networks of fewer than 30 workstations/users. No fancy enterprise IT stuff here. AVG is my antivirus of choice, but I usually hold off on installing it until after I get on client's site and install whatever programs they need on the server.

Anyway: the server from my OP is still doing fine since I reformatted it. I joined it to the client domain _before_ adding AD domain services role to it this time. It's fully patched as of this morning and has been rebooted several times since then, and no issues. I'm going to just reformat this other server that's still on my bench anyway, just thought it'd be interesting to mention here.
0
Hypercat (Deb)Commented:
Thanks for the update.  I think we've identified the culprit with the AD role installation.  Again, I can't think what exactly might be causing the blank screen, but adding the role does change the OS configuration significantly, and by the behavior it seems that it's causing this problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.