USB device Issues

I used Acronis Backup True Image to migrate my computer from old hardware to a new machine - a Dell to an HP machine.  I sysprepped the machine before my backup image was created, and after Windows re-discovered the hardware, it booted up.  I needed to run the HP drivers update program afterwards to smooth out some devices that Windows didn't recognize.  One of them was the USB hub.  Now, everything is working except for USB devices - they come up under "Other Devices" in Device Mgr, and are not recognized.  I do a Windows Internet search for a driver to no avail.   Not sure how to fix this now.
Damian_GardnerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

☠ MASQ ☠Commented:
What's the HP model and operating system?  Sounds like you're still missing the base chipset drivers for the motherboard
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gerwin Jansen, EE MVETopic Advisor Commented:
Tried deleting the not recognized devices in device manager? Windows should re-detect the removed hardware again. What does it detect?
0
nobusCommented:
yes, post the HP model; i suspect also that Masq is right
0
Damian_GardnerAuthor Commented:
wow - sorry guys.  I have no idea how I abandoned this.  so busy, I guess I forgot I opened this question, and I was about to open a new question for this same thing!  Anyway - thank you all for offering your help.  Let me try to answer you adequately:

MASQ - model is an HP PRODESK 600.  I thought of the chipset too, and I think I've ran all 3 of the possible chipset drivers offered on the HP site, and also rebooted each time.  all to no avail, so far.  Now since this was an image restore to different hardware, you'll notice in the screen shot I'm attaching, that it still thinks of itself as the original "OptiPlex 380". Don't know if that's a big issue or not.  I also have the Device Manager open so you can see the OTHER section.

See screenshot:  http://screencast.com/t/t1HEUZKt


GERWIN - yes, I've tried removing the unknown devices and letting Windows redetect.  it fails saying driver not found.  I checked the Device IDs, which are USB\VID_8087&PID_8000&REV_0004 and USB\VID_8087&PID_8000, and they come up as "Generic USB Hub".  When I search, I find hundreds of possible drivers it seems.  I've tried a few, to no avail so far.

NOBUS - I agree - it seems like a chipset issue - just not sure why the chipsets I've installed are not working.

Let me know what else I can post.  appreciate your help gentlemen.

Damian
0
Damian_GardnerAuthor Commented:
one more screen shot of the processor and USB hub devices installed:  http://screencast.com/t/yLZkelsfZ
0
Gerwin Jansen, EE MVETopic Advisor Commented:
Think you'd have to find a way to remove the Dell chipset drivers, they're most likely interfering with the HP drivers you're trying to install. Not sure how to do that though.
0
☠ MASQ ☠Commented:
Have you already tried Intel's C200 drivers?
https://downloadcenter.intel.com/download/21129

In Device Manager then try the "Scan for Hardware Changes" option

If there's still no change do the USB 2.0 ports work but not the USB 3.0's?

Somewhere in the mix as well is the problem with the cloned Win 7 MAK install carrying through the WMI settings that describe it as A Dell Opti 380 on the HP hardware.  

The other possibility is the Q85 Motherboard on the  ProDesk is affected by the Intel Haswell ChipsetBug.
0
nobusCommented:
you seem to have problems with the Acronis virtual disk; i found this :  https://forum.acronis.com/forum/28033
---
As I understand it (strictly UNofficial and subject to correction by one of the Acronis reps here) the Acronis Virtual Disk service is just used for mounting and handling a *.tib image file as a virtual disk to which an unused drive letter is assigned and which is then capable of being browsed just like any other drive using the Windows Explorer.
--
so i would uninstall ACRONis completely, and redo from the start - or use a different software, like Paragon  - here the free version :
http://www.paragon-software.com/home/br-free/download.html
1
☠ MASQ ☠Commented:
Good spot nobus, that'll be the Acronis device. So the reason Windows thinks it's still an Optiplex is because it is a virtual machine with Dell hardware. The HP/Intel drivers won't install because the actual hardware can't be seen by Windows.
0
Damian_GardnerAuthor Commented:
Ok - so uninstalling the Acronis may fix this?  I will try that.  

As far as which USB ports work - I have 2 devices I've been using to see if the ports work - a USB 3 thumb drive, and a Passport external drive (also 3.0).  those are both detected, but then unidentified in the OTHER section.  Only USB devices that work are my mouse and keyboard.  

So let me uninstall the Acronis first.  standby
0
nobusCommented:
'k
0
Damian_GardnerAuthor Commented:
Sorry for the delay guys - wasn't able to reboot until just recently.  I uninstalled Acronis and rebooted.  the error for Acronis is now gone, but the 2 other unknown devices (the USB hubs) are still there.  I asked Windows to try updating the driver by using the Internet - no dice.  So whats the next step, do you think.  Should I try updating the chipset drivers again?

thanks
0
☠ MASQ ☠Commented:
You need to establish if the machine that you're looking at is actually the ProDesk and not an image of the Optiplex running inside the ProDesk.  If you're working with the ProDesk then installing the drivers will work but if what you are looking at is actually a virtual machine environment the devices Windows sees are purely virtual copies of the Optiplex hardware so installing the HP drivers won't work.

Do you have a Win7 SP1 64bit bootable reinstallation DVD?
Suggest you boot to that, choose "Repair my computer"
See if a Windows partition is detected and connect to it then go to Command Prompt and explore the Hard drive.
That's the HP machine, are the drive contents what you are seeing when you're in Windows?
0
nobusCommented:
try my method for unknown devices :
Windows 7
=========
if you have  unknown devices in device manager, you can use this procedure to identify them :

1- visit the motherboard manufacturers support site, for downloading drivers
2- use windows update >optional updates to find them

3- Start>Programs>Accessories>System Tools>System Information.
Now select  "Components" and highlight "Problem Devices".
All hardware devices with a driver problem will be listed here.
Make a note of the first line of the PNP Device ID line of the entry. It will show a Vendor number and a Device number (VENxxxxDEVxxxx) both four digits long.
Look up those numbers here:   http://www.pcidatabase.com/index.php

This will tell you the manufacturer and the chip number.  
Check the manufacturer's website first or google them - or post them here

4- If your LAN is running, you can also use windows update> optional drivers, or  use a driver update software
0
Damian_GardnerAuthor Commented:
Ok - let me try your suggestions.  I didn't think about maybe trying the Dell OptiPlex drivers instead.  I'll boot to the Setup disc and check the drive contents for comparison.  then I'll try Nobus' idea next.  Standby

Thanks guys
0
Damian_GardnerAuthor Commented:
I wasn't able to boot off the setup disk - it kept saying "incorrect version of Windows".  I saw this before with another test machine I had worked on when I first started testing out the Acronis restore to dissimilar hardware.  I tried every version of Windows 7 I have, and none work :/  so, I'm moving on to the next thing, which is Nobus' hardware IDs.  Also - might it be worth trying to try installing the Dell OptiPlex 380 chipset?
0
nobusCommented:
if you click on start> My computer -then right click it and select options - it displays the version you have - and need
0
Damian_GardnerAuthor Commented:
yeah - its Windows 7 SP1 (2009).  it doesn't like this disc, however.    What do you think about loading Dell chipset drivers?
0
nobusCommented:
>>  Windows 7 SP1   <<  NO it's not it says if its home, pro or enterprise
0
Damian_GardnerAuthor Commented:
oh - I gotcha.  I'll check again
0
Damian_GardnerAuthor Commented:
I was able to get into the setup CD and run command prompt using a Windows Pro 64-bit (non-SP1), which was unexpected.  Anyway - I compared the root directory and they are a match.  So then I booted back up and tried running the OptiPlex 380 drivers CD to see if it detected any components that matched its drivers, and it did not find any.  I also went to Dell support online and had it try detecting the hardware, and it failed.  So now I'm back to trying to locate the explicit drivers for the unknown devices:

USB\VID_8087&PID_8000&REV_0004

and

USB\VID_8087&PID_8000


One is obviously a "parent" component to the other, and its related to the USB hub.
0
nobusCommented:
sure it says USB
i see some possibilities :
1-your usb controller is bad - and the mobo must be repalced for that
2-try running from a live Knoppix cd, and check your USB :  http://www.knopper.net/knoppix-mirrors/index-en.html
0
Damian_GardnerAuthor Commented:
Sorry - got sidetracked for a couple days.  How does Knoppix work?  do I need to put it on a bootable CD and boot to it?
0
nobusCommented:
it is an ISO file - that you burn on a DVD, with an iso burning tool
if you don't know how, just says so - i'll show it
and yes - then you boot from it, and test the problems on this OS -  which is different, and has different drivers
0
Damian_GardnerAuthor Commented:
no - I've done many of those.  I don't see an ISO file on the download page.  there's a bunch of different downloads.  let em take another look....
0
Damian_GardnerAuthor Commented:
I was able to load up Knoppix.  All USBs work fine in there.  so something must be wrong with the Win 7 OS.  should I maybe try upgrading to Win 8 to see if that fixes it??
0
Damian_GardnerAuthor Commented:
BTW - I tried MASQ's suggestion with installing the Intel C200 driver, but it said "hardware does not meet min requirements".
0
☠ MASQ ☠Commented:
OK hardware is good
I still believe that Acronis has convinced your Windows install that it's sitting on a Dell machine
Try killing the USB driver cache
See the instructions here
http://www.experts-exchange.com/questions/28697471/USB-device-not-recognized-mouse-Windows-7.html#a40883693
If you're not familiar with Unlocker read the article before installing.
Let's see if we can rebuild the driver cache around the hardware that is actually present.

(Alternatively - put in another HDD and create a new Win 7 machine on the HP this, like the Knoppix, will install the drivers correctly)
0
Damian_GardnerAuthor Commented:
ok - let me try unlocker...
0
nobusCommented:
try this - and reboot to test :
you see what it does in the link name
http://www.sysnative.com/forums/hardware-tutorials/3906-usb-driver-reset-usb-ports-power-state-reset.html
0
Damian_GardnerAuthor Commented:
I tried it, to no avail :/  starting to give up. nothing works.
0
nobusCommented:
since it's no hardware problem, upgrading to win8 or 10 can help
0
Damian_GardnerAuthor Commented:
ok. Well I'm going to keep searching for a while.  maybe something will eventually work.  thanks for your efforts, and I'll probably distribute the points soon.
0
nobusCommented:
if you happen to find anything - let us know
0
Damian_GardnerAuthor Commented:
I must have some unique problem. nothing works, so I'm just going to bite the bullet and rebuild it from the ground up.  thank you for your efforts.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.