change cisco 1711 by asa5505

Hi , i have on cisco 1711 with this configuration :

interface FastEthernet0
 ip address 172.22.X.1 255.255.255.252
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet1
 no ip address
 no cdp enable
!
interface FastEthernet2
 no ip address
 no cdp enable
!
interface Vlan1
 ip address 74.37.X.241 255.255.255.240
!
ip route 0.0.0.0 0.0.0.0 172.22.X.2

this configuration on 1711 work fine but i would like to replace it by a asa 5505 but it don't work with this configuration :


interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 74.37.X.241 255.255.255.240
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 172.22.X.1 255.255.255.252


object network obj_any
 subnet 0.0.0.0 0.0.0.0

object network obj_any
 nat (inside,outside) dynamic interface


route outside 0.0.0.0 0.0.0.0 172.22.X.2

i don't know why ?? maybe i miss something


Thanks and Regards
spmtAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NetExpert Network Solutions Pte LtdTechnical SpecialistCommented:
have you configured access-list on the ASA.

do you able to ping the gateway ip 172.22.X.2 from ASA outside interface
0
spmtAuthor Commented:
Hi ,
no i don't configure access-list on the ASA ,  no i can't ping 172.22.X.2 from ASA outside interface normally i can access routeur on  74.37.X.241 with cisco 1711

 my public ip address is on inside so i need cross private network on outside interface  before access to internet with cisco 1711 it's  works fine but when i put the asa it doesn't works .

Thanks And Regards
Rudy
0
NetExpert Network Solutions Pte LtdTechnical SpecialistCommented:
Can you draw your current network topology with CISCO 1711 and proposed topology with ASA
0
egyptcoCommented:
Hi spmt,

try to configure the physical interfaces of the asa (without vlan)

interface Ethernet0/0
 nameif outside
 security-level 0
 ip address 172.22.X.1 255.255.255.252

route outside 0.0.0.0 0.0.0.0 172.22.X.2

to allow pings trough the asa you need to enable icmp inspect in the global policy

policy-map global_policy
 class inspection_default
   inspect icmp
   inspec icmp error

this should be enough to ping the default gateway from the asa
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
spmtAuthor Commented:
Thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.