t-sql Export to Excel

in the sql results is showing customer number is 01NOV02,02NOV02..etc, after export to the Microsoft Excel sheet ,its showing the 01-Nov-02.
I try usig Convert (varchar(50,[Customer Number])) but after export to the excel its showing date format (01-Nov-02.
) how to export to the Excel with out changing to the dae format?

Many thanks
LVL 10
ukerandiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jim HornMicrosoft SQL Server Data DudeCommented:
The problem isn't that SQL Server is pumping data in the incorrect format, it's the way Excel interprets the data type of that data when it's opened.   So, your options are to either pump the data with a single apostrophe ( ' ) in the front so Excel can interpret it as a string, or write Excel VBA code in the startup function to format the column as a string.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RayData AnalystCommented:
You can export to a csv or txt file then open excel (not the file itself, just Excel), then use the Excel "File" menu to "open" the file, but BEFORE opening use the options at the bottom of the window to "import" the file.  Ensure you set that column as TEXT before allowing it to import.
HuaMin ChenProblem resolverCommented:
Try to put

 ''''+'01NOV02'

on t-Sql, to make it as one char field instead.
Ryan ChongBusiness Systems Analyst , ex-Senior Application EngineerCommented:
>>how to export to the Excel with out changing to the dae format?
when you try to import them, set the column data format as Text

column data format to Text
Ryan ChongBusiness Systems Analyst , ex-Senior Application EngineerCommented:
sorry, disregard comment ID: 40962103 as didn't see Ray already posted same suggestion.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.