w2k12 r2 wsus server not receiving client connections

i setup a new wsus role on a w2k12 r2 server.   i believe i have the gpo setup properly and that it is being applied, as all pc's in that ou now have update settings greyed out.   i have set the update server location as http://<wsusservername>:8530.   yet no clients have checked in with the server. this is on one subnet and domain and i have turned off firewall between the wsus server and test clients.   most documentation i have read makes this seem like a pretty straight forward process.  what am i missing?

the wsus server in question is also configured for rds gateway, broker and web.

thanks in advance.
LVL 4
alexsupertrampAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mal OsborneAlpha GeekCommented:
First thing to do would be to open C:\windows\windowsupdate.log.

It can be a tad difficult to read, but should give you some insight. Check the link below for guidance, and maybe zip and post the log here.


 https://support.microsoft.com/en-us/kb/902093
0
Cliff GaliherCommented:
Running RDWA and WSUS on the same server is a downright pain. You'd have to do some unsupported edits in IIS to get them to coexist. That's at least some of your problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Seth SimmonsSr. Systems AdministratorCommented:
if you run windows update manually on a client, what does it do?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

alexsupertrampAuthor Commented:
alright, thanks cliff.  i'll start there and move to a w2k8 r2 server that is not running anything else on iis.
0
alexsupertrampAuthor Commented:
seth, the manual update failed almost immediately before i set the port to 8530 but then after about 30 seconds after i made the port adjustment in gpo.
0
Seth SimmonsSr. Systems AdministratorCommented:
ok, so you changed the port, ran windows update again and...?
did it error out, or did it say there are no updates?  if there are no updates then it should be working
how do you have the computer groups configured?  does the gpo have client-side targeting enabled?
usually after a short time when the windows update client runs, it will show in the console with a status of 'not yet reported' but after a little while it will update

another way to force a check is to do (from an elevated command prompt) wuauclt /detectnow
there won't be any output but will check for updates and update itself in the console
0
alexsupertrampAuthor Commented:
after i changed the port a manual update  returns a "windows could not search for new updates" error with the "x" inside the red shield.  if i choose the option "get updates online" it allows me to go out to the internet and download them from ms.

i am in the middle of setting up a different server without the iis conflict and i am seeing some difference in the result, in that some workstations are showing up in the console.  i will let this bake for a day and will check in on it tomorrow.  thanks.
0
yo_beeDirector of Information TechnologyCommented:
Have you cleared the clients reg settings and reset.  If the above does not resolve the issue try running this bat.

I ran into a similar issue back in the day on my 2003 WSUS and this resolved the issue.  I recently gave  someone this bat and it resolved his issue.

https://gallery.technet.microsoft.com/scriptcenter/Reset-WSUS-Authorization-2e26d1b0
0
alexsupertrampAuthor Commented:
Thank you everyone for your help.  I installed the wsus role on a new vm instance and things worked more like one would expect.  Lesson learned....trying to run this with other roles is not recommended.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.