Not able to uninstall Microsoft Office Visio Professional 2007 on my Windows 7 PC.

My Outlook 2013 client got corrupt. I attempted to re-install it, but keep getting the following message (see screenshot). I uninstalled Office 2013 successfully. I also need to uninstall Visio 2007, but that is where I am having difficulties. First, I couldnt uninstall from Control panel. Then I use Microsoft Fixit tool, but it only removed Office 2007 and left Visio 2007 on my PC. I tried Perfect Uninstaller as well, but still to no avail. I followed the manual process to delete it entirely but no luck. I am out of options here. How can I fully uninstall Visio Pro 2007 on my PC?

 2015-09-03_21-53-00.png
joukiejoukAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

helpfinderIT ConsultantCommented:
if you try to delete it in Program Files, then run Ccleaner to clean up registry and remove it from Programs and Features?

I think this could workd if nothing else is.
0
☠ MASQ ☠Commented:
Did you try extracting the OffScrub07 component from the FixIt tool?
It would be useful to see if VisPro is still detected as an installed product
See the instructions here on how to do this if you've not already found them.

http://blogs.technet.com/b/odsupport/archive/2011/04/08/how-to-obtain-and-use-offscrub-to-automate-the-uninstallation-of-office-products.aspx


Also OffScrub07 usually works best in Safe Mode if you're getting the "Installation Corrupted" errors.
0
nobusCommented:
i recommend revo uninstaller : http://www.revouninstaller.com/
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

joukiejoukAuthor Commented:
MASQ,

I followed your suggestion, and it did got me further. However, now, I get the following error when i run setup. I tried disabling AV, stopping print spooler, and even tried to run setup in Safe Mode, but to no avail.

2015-09-04_9-45-37.png2015-09-04_9-46-04.png
0
☠ MASQ ☠Commented:
If Visio has now gone, you'll need to run Office Quick Repair to fix 2013
The scrubber has probably taken out some common files with the same name in both Office versions


https://support.office.com/en-NZ/Article/Repair-an-Office-application-7821d4b6-7c1d-4205-aa0e-a6b40c5bb88b
0
joukiejoukAuthor Commented:
Office products are no longer showing in Programs and feature, so I am not able to do a quick repair.
0
☠ MASQ ☠Commented:
Can you run Setup with enhanced admin (right-click 'Run as admin')?

Try a customised install of 2013 but remove the Microsoft Office Telemetry Tool option from the install selection before running.
0
joukiejoukAuthor Commented:
Is this what you are referring to? If so, I removed it from setup, but still continue to get the same error.

2015-09-04_13-17-17.png
0
nobusCommented:
try Revo...it does a rather good job on uninstalls
0
☠ MASQ ☠Commented:
Good idea, let's see if Revo finds anything else the scrubber left behind.  If there's still a problem there are a few other thing s to try yet.  Sometimes when OSE is removed forcibly it takes out some other Windows service dependencies like Task Scheduler.

joukiejouk in answer to your last question, yes, although you can open the Office Tools tree and just deselect the individual component.  Time zones and sleep got in the way of an earlier response :)
0
joukiejoukAuthor Commented:
I installed and launched Revo, but it found no instance of Microsoft Office. I've exhausted all troubleshooting steps. Anything else I can try?

2015-09-05_22-17-07.png
0
nobusCommented:
did you uuninstall it before using revo?

then you may have to reinstall it first
0
☠ MASQ ☠Commented:
"then you may have to reinstall it first" - that's the problem! :)

Can you see if there's an installation log in your %temp% folder (named Microsoft Office Setup 2013.txt) can you look st the last few lines to see what's stalling?  

Task Scheduler can be one of the culprits if it's nor running as a service at install
http://shubhamohanty.blogspot.nl/2013/01/office-2013-installation-error-code-1603.html
0
nobusCommented:
or do a system restore before all the above was tried
0
joukiejoukAuthor Commented:
Task scheduler is enabled. I was not able to do a system restore because it was never enabled. I've attached a log here for when I try to run setup. If someone can look at the logs to determine what the culprit is, I would appreciate it. I'm out of luck here.
SetupExe-201509071418061AAC-.log
0
☠ MASQ ☠Commented:
Interesting, it looks from the log as if the installation stalls because a previous installation had failed and left folders locked to prevent sharing.

Try this FixIt
It's from a previous version of Office but it addresses the same issue.
This should remove the folder locks, it it appears to run successfully then try to reinstall again (as administrator)

This is the KB article that I think is relevant to what's happening (but for Office 2010)
https://support.microsoft.com/en-us/kb/927153

BTW the log shows that remnants of the Visio install are still present but these aren't interfering with the Office reinstall.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusCommented:
i hope you enabled system restore now? can be of help later
0
joukiejoukAuthor Commented:
I seem to be getting a little further now. I tried running setup, and this time it installed successfully. However, now I go to All Programs, look for the apps, and this is now what I see (screenshot). I tried uninstalling and re-installing again with the same results.

2015-09-08_22-18-33.png
0
nobusCommented:
so the bootstrapper problem is solved?
an d you still  cannot install visio?
0
☠ MASQ ☠Commented:
If you type Winword into the search and hit enter does Word 2013 launch?
Can you post the newest Setup log?
0
joukiejoukAuthor Commented:
Typing winword in the run line seems to launch the app, as well as other Office app just fine. How do I fix the icon issue? I don't want to type in winword each time I need to launch Word.
0
☠ MASQ ☠Commented:
See if you now have the Quick Repair option that was missing earlier in the thread.

It would still be helpful to see the setup log to see why the script installing the Start menu icons didn't run correctly.

Another option is you could just manually map each of the icons through their properties, but it would be good to know there aren't any other "gotchas" waiting where the install hasn't run completely.
0
joukiejoukAuthor Commented:
I did the repair install from Add/Remove programs, but still the issue remain. Attached are the latest logs when I ran the setup. Also, screenshot below will show the path for Office 2013. In looking at the image, how do I manually map the .exe to the icons in the start menu?

2015-09-09_21-06-10.pngSetupExe-201509082325031798-.log
0
☠ MASQ ☠Commented:
Default path for Office 2013 x64 is C:\Program Files\Microsoft Office 15\root\office15


At first glance it looks like there are still registry references to the older Office install which are pointing to an Office icon cache that no longer exists. So although 2013 is working the Start menu is pointing at the right file location but the wrong icons and because the old icons are gone you've got blank place holders filling in the gaps.

I'll try to have a proper look through the log again later but busy couple of days ahead here.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.