32G USB stick

I have a 32G usb stick and after reformating it, it says I have only 3G capacity. How do I fix this? Thanks
LVL 1
leblancAccountingAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
What did you format it with? Fat16, fat32
leblancAccountingAuthor Commented:
fat32 (default
arnoldCommented:
That is strange, what are you using to format? What system are you on?
List the partitions to make sure you did not split/limit the size .............
Make of USB stick?
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

nobusCommented:
rindiCommented:
Format it using the tool included with WinSetupFromUSB, it is very good in properly formatting USB sticks.

http://www.winsetupfromusb.com/downloads/
nobusCommented:
he only formatted the stick, rindi
i don't beleive he wants to install windows from it
rindiCommented:
He doesn't need to install Windows with it. The tool includes further utilities, at least one of them is a very formatting tool for USB sticks and SD memory cards.
nobusCommented:
well - i have no evidence of such tool being better for the task than windows ; but maybe you have some?
rindiCommented:
Yes, I've sometimes had problems formatting USB sticks or removing partitions on them using Windows diskmanagement, while the tools that are built for those media tend to always work provided the stick or card is still OK.
JohnBusiness Consultant (Owner)Commented:
I have a 64 GB USB stick that started to give issues and I put it aside.

I just attached it to my Windows 7 machine, right clicked and said Format.  It says:

60 GB (correct)
exFAT (default)
Allocation unit 128 Kb

I just unchecked Quick Format and will see what happens

Did you try exFAT ?
leblancAccountingAuthor Commented:
My stick worked fine with 32G before. Then I want to make it a bootable usb with kali linux iso. So I used rufus. After rufus did its thing, it said to reformat the usb, which I think is  akind of weird. But I did not do it. So I tried to open the usb under win exploere and it said i needed to format the USB. That is where I see it is only 3G capacity. I do no think this usb is a fake because I have been using this usb stick for a while now. I have never had any issue until now.

It is an Extreme Sandisk 32G BTW
rindiCommented:
I haven't used rufus, but it probably creates a partition of the size it needs for the OS you want on it. Windows can only handle one partition on a USB stick. So you don't see the rest of it. That is also one of the advantages of using WinSetupFromUSB to create your bootable stick. It can use the total size of the stick, as it creates a boot menu, and then accesses the iso file of the OS you want to boot from directly, while other tools extract the content from those files. Further advantages are that you can have more than one iso to boot from, including Linux, not just Windows which the tool's name would imply.
JohnBusiness Consultant (Owner)Commented:
I formatted my 64 GB key exFAT and it showed all 64 GB on completion. So if not the multiple partition issue alluded to above, then see if exFAT works.
nobusCommented:
you don't have to believe - test the stick with the tools i provided; that's all
leblancAccountingAuthor Commented:
Ok. I look in diskmgmt.msc and this is what I got (see below). It is there and it is unallocated. How do I get my 32G back?

diskmgmt
rindiCommented:
As I said, either use the format option in WinsetupFromESB I mentioned earlier (that is the best way in my point of view, as it properly formats it), or try using Windows Diskmanagement, delete any partition on the stick, then create a new one and format that.
leblancAccountingAuthor Commented:
I right click on the unallocated to try to delete but I don't have the delete option.
rindiCommented:
The un-allocated space already has nothing on it. You have to do that with the space that is allocated.
JohnBusiness Consultant (Owner)Commented:
Try what rindi recommends or try formatting it again on a Windows machine.

It is not a volume in the sense of a hard drive so Delete is not active.
arnoldCommented:
the wrong partition was formatted. Or the partitioning error ...


often USB sticks are spout with having a small partition that includes apps/and other tools, while the bulk remaining partition is for data.

Use diskpart to delete the first and second partition, then create one single partition spanning the whole USB stick 32Gb. Then format it.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.