WordPress Editor tool bar I have doesn't match what is in product documentation.

I am in the process of converting my EarthLink hosted website built with EarthLink provided website creation tool Trellix to WordPress. EarthLink also provided the WordPress installation functionality. The WordPress installed by Earthlink has been behaving pretty much as expected. But I noticed when I tried to add a HTML table builder tool to the top tool bar that the toolbar I have in the WP editor is different than shown in the setup screen for configuring the WP editor. I noticed the same difference when I tried to get a solution off of YouTube.com. I have thoroughly examined my WP Editor environment and read as much about this situation in WP provided documentation without finding a solution. I am adding a BAD and a GOOD screen shot of the WP Editor toolbars.

I didn't know that I could insert an image.

BAD:
Snapshot image of WordPress toolbar that is just plain wrong.
GOOD:
Snapshot image of WordPress toolbar that I want to have -- matches documentation
Looking forward to seeing how these embedded images are going to turn out after I submit my question.

It appears to me like I have reduced privileges from my logon. Like I am not administrator of my own WordPress instance. I noticed that the WordPress Editor toolbar is wrong on another WordPress website that I have hosted by a completely different vendor. And I know that I am not Administrator on that particular instance of WordPress.
WordPressEditorToolBar-Bad.jpg
WordPressEditorToolBar-Good.jpg
Ted PalmerInformation Technology ConsultantAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jason C. LevineDon't talk to me.Commented:
The top screenshot is the Wordpress editor in "text" or source code mode.  The bottom is in "visual" or wysiwyg mode.  You should have tabs to the right of the editor that allows you to switch between them.
Ted PalmerInformation Technology ConsultantAuthor Commented:
I avoid Visual mode like the plague because it changes my content that I type on me on a rather grand scale. I got tired of having to go back and fix it. I even clicked a check box to not even show the visual tab. I'll go back and change it and see what happens. I guess I may have to endure Visual mode to get the other tool bar buttons that I really need.

Back in a few minutes . . . .
Jason C. LevineDon't talk to me.Commented:
I avoid Visual mode like the plague because it changes my content that I type on me on a rather grand scale.

Visual mode has functions that will remove/correct invalidly nested HTML and WordPress has a function called wpautop that will change what you post.  Both functions can be disabled via functions.php if you wish.

But the buttons are correct for those modes.  If you cannot learn to use Visual mode, you will need to learn how to get along with typing HTML.  Your other option is to download the TinyMCE Advanced plugin as that will give you additional configuration options for the visual editor.
Bootstrap 4: Exploring New Features

Learn how to use and navigate the new features included in Bootstrap 4, the most popular HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites.

Ted PalmerInformation Technology ConsultantAuthor Commented:
Thank you for the advice. Now I know what one the advantages of TinyMCE are. I learn a lot from using Experts-Exchange. That is why I have it. I'm still looking for that check box that I checked to not show Visual tab. If you know where it is at, I'm not too proud to accept your help on that.
Jason C. LevineDon't talk to me.Commented:
No idea.  That's not a standard WordPress function.  It may have been something added by a plugin or theme.
Ted PalmerInformation Technology ConsultantAuthor Commented:
Jason,

I finally found the option that I had checked to remove the Visual/Text mode tabs on the WP Editor. It was on a per page basis so I had to go back and visit each page that I have created to uncheck it. The option I had checked was provided by the theme Weaver Xtreme.

Weaver Xtreme Options for this page -- Disable Visual Editor for this page. Useful if you enter simple HTML or other code.

Now that I have unchecked it. The Visual/Text mode tabs won't come back. I logged off and logged back in. But that didn't help. Have you got any suggestions as to how I might restore  the Visual/Text mode tabs on the WP Editor?
Ted PalmerInformation Technology ConsultantAuthor Commented:
Jason,

I have information from additional research. I accessed another WordPress blog that I have working at a different URL. It uses Wintersong Pro Theme. I don't know where it came from. It was provided by the website that hosts that blog. The WordPress editor on that blog behaves as you and I would both expect it to behave including the editor tool bar that is displayed depending on which Visual/Text mode is selected.

That causes me to suspect that the Weaver Xtreme theme has got a bug in it. The provider of that theme acknowledges that it is the new latest evolution of his product. Previous evolutions of it were named Weaver II and Aspen. I'll politely ask in that theme website's forum about why the Visual/Text mode tabs in the WordPress editor didn't restore after deselecting the check box that made it go away.
Jason C. LevineDon't talk to me.Commented:
I don't use Weaver (for reasons wide and varied).  You can always test things/force changes by switching to a new theme, verifying that the editor functions as expected, then switch back to Weaver and see if it reset to norm. If not, there is most likely a bug in the theme.
Ted PalmerInformation Technology ConsultantAuthor Commented:
Jason,

I posted to the Weaver Xtreme forum. Mr. Weaver as he is known on his forum responded with a moderately aggressive defense of his product asking me to perform certain tests to prove to his satisfaction that his product does indeed have a bug in it. I have 4 screen shots that I have to upload to his forum. The forum software does not have image upload functionality. I can only add images to my posts on Weaver forum by entering the internet URL to the image file. So therefore to obtain an internet URL to my the image files I have to get them on a webpage somewhere. EE is the best somewhere that I know of to do this. It worked the last time I made my original post. So here are the images in the order I made them.Add New Page Test Top Half. Too big for one screen shot.
Ted PalmerInformation Technology ConsultantAuthor Commented:
I wasn't finished adding screen shots when the EE webpage submitted my comment. I may have hit return too many times?
AddNewPage-Test-BottomHalf.
PreviewAddNewTESTpage.
AllPluginsInstalledInMyInstanceOfWordPressUsingWeaverXtremeTheme.
Jason C. LevineDon't talk to me.Commented:
What do you expect me to say?  As far as I am concerned, this problem is solved: it's a theme issue and you and the theme author will need to resolve it. I will not provide support for someone else's paid theme.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ted PalmerInformation Technology ConsultantAuthor Commented:
Jason,

I see your point and I agree with you. But I have a second tech support person helping me right now. And they are not yet conceding that it is a theme problem. They have given me two more things to try. One of them is what you suggested about temporarily changing the theme to see if that brings back the Visual/Text tabs. I told them I have to backup what I have got first. That could take a while. It's been a while since I have done a full backup anyway. So I have to do that first. You'll get the 500 points soon but not right away. I need to keep this thread open to use to load image files to the Weaver Forum. That is all I have got for doing that. So I'll have to see what I can do so that I don't have to use EE to have a place to store my snapshot screen images so that I can insert them into my Weaver posts. That doesn't seem right but for now that is what I have to do to survive.
Ted PalmerInformation Technology ConsultantAuthor Commented:
Jason.

I can only insert my images onto Weaver Xtreme forum by referencing a URL like http://yada.yada.com This is the first forum that I have seen that is like that. So that is what I have to work with for now.
Ted PalmerInformation Technology ConsultantAuthor Commented:
Thank you for your help and patience.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
WordPress

From novice to tech pro — start learning today.