Reverted to Win 7 after upgrading to Win 10 but have problems

I upgraded my Toshiba T235 computer to Windows 10 but it had several problems. I used "Go back to Windows 7" to revert to Win 7 but the computer does not recognize the built in keyboard or mouse. I plugged in an USB mouse and keyboard. The computer saw the mouse but not the keyboard. With the mouse, I was able to get to device manager where first I uninstalled the keyboard and mouse drivers and rebooted. Then I tried updating the drivers to every driver listed and allowing windows to search for drivers. All has not helped.

In also cannot get on the internet to find drivers as the computer shows my home computer as "Unidentified network". I removed the network, reconnected and entered the password but it still shows Unidentified network.

Any ideas? Thanks.
LVL 39
thenelsonAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

☠ MASQ ☠Commented:
Is Keyboard now recognised?

Wired or Wireless connection? Fixed IP or DHCP?

Try restarting your router first but then if you're still not connecting remove your network connector driver and reinstall the Windows 7 one.  

Windows Update isn't good at realising a more recent driver that says it will work should be replaced with an older one that actually does work!

If it's still not working try FSS to check if any on the networking services have been broken by the downgrade
http://www.bleepingcomputer.com/download/farbar-service-scanner/

Just check Internet Services - hit Scan, check you're happy with the output being posted publicly and put it in your next post.
thenelsonAuthor Commented:
Keyboard is still not recognized: built in or USB.

Wireless connection,  DHCP

Restarted router and tried another listed driver for the wireless card. No help. I ran the troubleshooter, it states there is a problem with the driver. The connection window shows: Unidentified network, No internet access and in the list: JaneNelson (our network) Connected. Device manager shows Atheros AR9285 Wireless Network Adapter showing working normally.

In device manager under keyboards it shows Standard PS/2 Keyboard and Windows cannot load the device driver for the hardware. I get the same message for all other drivers listed.

Under Mice it shows Synaptics PS/2 Port TouchPad with the device cannot start. I get the same error for all other drivers listed.

Device manager
☠ MASQ ☠Commented:
Which 235 is it?  If it has USB 3 make sure the Win 7 drivers are reinstalled.

64bit Windows 7?

It it getting an IP address on your Network?

If it is, can it see any other resources within the network (other computers, the router, networked printers etc)?

Looks like your drivers have been messed up by the downgrade, hence the Code 10 - 'cannot start' - errors, let's try putting back the ones that should have come with it starting with those for the system board.

Should point out at this stage that a fresh install of Win 7 from scratch will fix this but you'll lose anything on the computer and spend a while on Windows Updates.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

thenelsonAuthor Commented:
T235D, AMD processor, 64 bit

I can't run ipconf without a keyboard. I cannot see any other computers or resources. Double clicking on "Unidentified network" in Network and Sharing Center shows "Network discovery is turned off. Network computers and devices are not visible. Click to change." I clicked then rebooted - no change.

What does tc40110900a.exe do?

I don't have a recovery disk or Win 7 disk to reinstall Windows. I am starting another full backup of all my files to an external disk now just to be sure.
☠ MASQ ☠Commented:
tc40110900a.exe installs the basic chipset drivers for your system board

Can you use the mouse to get to C:\Windows\System32\osk.exe ?
That'll at least give you a kind of keyboard access
thenelsonAuthor Commented:
Yes, I am able to use the osk (I forgot for ipconfig)
ipconfig on the Toshiba is showing 169.254.159.243 which is wrong, it should be 192.168.0
☠ MASQ ☠Commented:
OK, so despite what Windows is telling you about connecting - it's not :(

Do the Win 7 chipset drivers install?

The 235D AMD Model comes with a choice of 2 different Realtek WiFi chipsets, a Broadcom and an Atheros Wireless card.

As the current setup seems to have selected Atheros - this is the Win 7 version

Atheros Wireless LAN Driver for Windows 7 (32/64)
http://cdgenp01.csd.toshiba.com/content/support/downloads/TC00190600I.exe

All the models come with a single Realtek Ethernet NIC so while you are getting this fixed you might be better just installing that.

If you haven't found it already the Toshiba drivers can be downloaded from
http://support.toshiba.com/support/modelHome?freeText=2760024


It might also be helpful to install Toshiba's HWSetUp utility to see what it "thinks" you have available as options.

Toshiba HW Setup Utility
http://cdgenp01.csd.toshiba.com/content/support/downloads/tc40116200c.exe
GauthierCommented:
Try to boot in safe mode your keyboard should work in safe mode, run a sfc /scannow
If the keyboard is not working in safe mode, power off and remove the battery
thenelsonAuthor Commented:
I tried running Toshiba HW Setup Utility first: no help.
Then I tried Atheros Wireless LAN Driver for Windows 7 (32/64): no change
Then I tried Realtek Wireless LAN Driver: no change
thenelsonAuthor Commented:
The keyboard and built in mouse do not work in safe mode also. I removed the battery for about two minutes. Reinstalled and rebooted - no change.
GauthierCommented:
Does the keyboard works in the system BIOS ?
Did you run SFC ?
The keyboard is a very basic system and very little can interfere with it, especially as both PS/2 and USB.
The only guess I have would be the system cryptography is toasted and thus fail the driver signing.
Can you check the event viewer?
☠ MASQ ☠Commented:
OK, let's concentrate on getting you online.
Try running the following from a CMD prompt opened with 'Run as Admin'
ipconfig /flushdns 
nbtstat -R 
nbtstat -RR 
netsh int ip reset c:\resetlog.txt 
netsh winsock reset 
exit

Open in new window


Then restart the laptop.

Did you install the Realtek NIC driver to allow Ethernet access?
thenelsonAuthor Commented:
Gauthier,
The keyboard works in in the BIOS.
SFC reported: "...found corrupt files but was unable fix some of them." I attached the cbs.log
Which log of the event viewer do you want me to check?

MASQ,
I followed all the steps but no change.
CBS.txt
GauthierCommented:
The only files in the CBS with recognized problems are related to
https://support.microsoft.com/en-us/kb/3068708 
(Update for customer experience and diagnostic telemetry)
I doubt it relate to your keyboard problem, you may try to uninstall that.
If not present, you can uninstall KB3022345 or install KB3068708 manually (if an USB key is recognized).
Check for all Critical and errors (those in red) in the system event log since the last boot.
There may be quite a lot, so concentrate on those up to the driver failure to start.
GauthierCommented:
Unless the logs gives you strong indication that the network problem is related to your keyboard problem, then if the previous poster universal network problem solver script fail, you may want to try a wired connection. If that fail too then uninstall your antivirus.
GauthierCommented:
In the CBS.log there are also way too many CBS_E_INVALID_PACKAGE, I guess a failing HDD is a strong possibility.
Check for disk, ntfs warning and errors in the system event log.
GauthierCommented:
Also the SFC did a lot of repair including in the IME (Input Method Editor) keyboard related!!!
Did you reboot after the SFC to apply the corrections?
☠ MASQ ☠Commented:
Sorry but from what we've tried already and the CBS log I really think this is messed up too much to fix :(  I don't think your hardware has coincidentally become damaged though, this is entirely down to the operating system.

Can we start checking for alternative options?

You said you had no recovery DVD but check if you still have a functional recovery partition on the laptop.
Shut down and before pressing the power button press and hold the "0" key then power up holding the "0" key down.
If installed, this will launch the Toshiba Recovery Wizard, you don't need to run this right now but it'll help knowing that it's still available as an option.  If it is present and you want to run it it will erase all your data and return the laptop to its state when it was first supplied (and will need a load of updates) but it will work normally again.
vivigattCommented:
There are too many issues with Windows recognizing the devices and using the correct drivers.
As long as these issues are not resolved, trying to get you connected is going to be very hard.

What I suggest is (in that order)

Option 1 :
Open device manager (Right click on My Computer/Manage/Device Manager)
Enable hidden devices (View/Show hidden devices)
Remove all drivers/devices with a red or yellow icon
Don't reboot until you removed all the problematic drivers even if Windows asks you to do it. It would be a waste of time
Remove the PS/2 keyboard and mouse driver
When no drivers with a yellow or red icon are present then reboot and let Windows detect the devices. It may take some time so be patient (sometimes up to 10-15 minutes before you get your mouse and keyboard)
Be sure to have all chipset and keyboard/mouse drivers available as well as the network drivers, for instance on a USB key/drive. You may have to download said drivers using another computer.

Option 2:
Find a Windows 7 installation DVD that fits your version of Windows and attempt a Repair installation.

Option 3:
Connect some USB drive to the computer, backup all the data files you want to save and re-install Windows 7 from scratch (format the system partition and then install).
thenelsonAuthor Commented:
I did  reboot after the SFC.

"power button press and hold the "0" key"
Doing a clean install and recovering everything will be very time consuming. The Toshiba computer was giving hints of giving out so I bought a used Dell E6410 computer to transfer to. I think my best use of my time is to transfer to the Dell computer. Once I get the Dell up and running, I will go back to the Toshiba to see if I can get it running as a back up.

I think I got all my data backed up from the Toshiba to transfer to the Dell. Of course, once I start using the Dell, I may find other files I still need. Getting the keyboard of the Toshiba would simplify backing up data from it. Any ideas on how to do that easily?
vivigattCommented:
Extract the HDD from the Toshiba, mount it in a USB storage case and voilà.
Your data are now all on the "external" HDD (which once was your Toshibas's internal HDD)
GauthierCommented:
I usually either remove the HDD and connect it trough SATA in a tower (As suggested by vivigatt) or Boot to a variation of WinPE (there are quite a few to chose from) from an USB key or a DVD.

The command I use to backup user data from a privileged cmd.exe:
robocopy c:\users x:\users /E /R:0 /W:0 /XJ /DCOPY:DAT /COPY:DAT
attrib -H -S x:\users

Open in new window


Note that that is not a garantee to be able to restore the data, for some program like Windows Live Mail, some address book, etc it may be preferable to export beforehand as restoring the files is likely to not make them accessible within the app on the other machine, the file format being often proprietary, it's a very unhappy situation...
thenelsonAuthor Commented:
vivigatt,

I followed option 1.  There were several problem drivers under system devices that resolved. But my Standard PS/2 Keyboard driver still shows: "Windows cannot load the device driver.... (Code 39)" and the Synaptics PS/2  Port Touchpad driver still shows: "The device cannot start (Code 10)." The built in keyboard and mouse still do not work and the network is still showing "Unidentified network. No Internet Access".

I will see if I can find a Win 7 Home Premium installation DVD.

MASQ,

Holding down 0 while starting brings up "Windows Boot Manager" with "Windows Setup [EMS Enabled], press F8 for advanced options and "Windows Memory Diagnostic" as options.  I wonder if this could be used to repair the installation as vivigatt suggests for option 2?
GauthierCommented:
Beware that the Windows DVD must be of the same service pack level as the current installation.
vivigattCommented:
You may have to replace the files that make the PS/2 devices working with the ones for your system:
i8042prt.sys
mouclass.sys
kbdclass.sys

All in C:\windows\system32\drivers

If you have another Windows 7 machine working, you may get them from there.
But in order to copy them to this location from the running OS itself, you need to disable some system protection. Or to boot off some other OS that can read your HDD (WinPE, Linux LiveCD...).
Or extract the HDD, connect it as a secondary drive to some other computer (via USB, sata etc) and copy the files from there.
thenelsonAuthor Commented:
vivigatt,

I extracted the HDD, connected it as a secondary drive to some other computer but it still said I do not have permission to overwrite or delete the three files.

The three files have the same date/time and size as the files on the other computer so I would guess they are not corrupt.
☠ MASQ ☠Commented:
"Windows Setup [EMS Enabled]" starts the process to reset the system to it's "out of the box" state (wipe everything and begin from scratch)
vivigattCommented:
Run explorer or cmd as administrator on the other computer and try to overwrite the files.
Size and date might appear correct, but you lay want to run file compare to make sure they are the same (fc /b as far as I can recall)
thenelsonAuthor Commented:
I have switched to my new to me computer. After about another month when I know I don't need something on the old computer, I'm going to do a clean install of Win 7 on it. I am planning to give the points to MASQ who is the first person to suggest the clean install. A lot of people have made good suggestions which unfortunately did not pan out. Please let me know if you think you should share in the points before I close this question.

Thanks to all.
thenelsonAuthor Commented:
i ended up doing a clean install of Win 7 after I was sure that I got everything important out of the computer.
Thanks for your help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.