Links within Outlook 2010 will not open with IE, only with edge

Hi experts.

What I have here seems to be a nasty bug since it happens on all win10 systems. We run outlook 2010 and when we click a hyperlink, outlook asks what to use to open that link...IE11, or edge, or chrome, or...
If we select edge or chrome, all is good, it never asks again. If we select IE11, it keeps on asking every time, even if we select not to ask any further. Note: setting up IE11 to be the default browser does not change that.

Note2: this happens only within outlook (and only on win10), no other program shows this behavior. So I wonder (and my question is):
what is so special about links in outlook that they are treated differently than (the same) links in for example a word document?

So far, the solution is to deploy a new default browser (chrome, since edge is not capable of certain other things), but we'd prefer to keep IE11 to be the default.
LVL 63
McKnifeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Benjamin VoglarIT ProCommented:
The problem affects Outlook 2010.

Is 2010 outlook which does not store the selection IE.

If you do not have Outlook 2010 so there is no problem for you.

This is known issue and there is no solution for this.

Many users report, that MS do not wont to fix this problem. They want you to upgrade.
McKnifeAuthor Commented:
Hi.

"known issue, no solution" - where did you read this?
JohnBusiness Consultant (Owner)Commented:
I cannot comment on the Outlook 2010 issue (that is "no solution"). But I can say that clicking a link in Outlook 2013 in Windows 10 Pro opens immediately with IE11 (and IE11 is my default browser).

There is a FixIT for Outlook links but it is not up to date for Windows 10 but it is for Outlook.

https://support.microsoft.com/en-us/kb/310049

In Word the Hover text says Ctrl+Click to follow link; In Outlook the Hover text says Click to follow link. The two applications are different.
McKnifeAuthor Commented:
Self solved.

It is a bug, what else.
http://answers.microsoft.com/en-us/ie/forum/ie11-iewindows_10/outlook-2010-and-windows-10/2a06143e-54ae-48ec-9139-ae2dceb7af34?auth=1 leads to this registry file:
Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\htmlfile\shell\opennew\command]
@="cmd /c start \"IE\" \"%1\""

Open in new window

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeAuthor Commented:
Self-solved.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.