Default language for Grandstream 1165 is espaniol with Elastix as IP PBX

Dear Experts,

I've just installed Elastix. I am using Grandstream 1165 as IP phones. When I am trying to provision a phone, the configuration file which is created for the phone has the language set to "es" (P1362) and as the result, the phone's language menu is in Spanish.

My question is where from the Elastix extracts this P1362 parameter and put it in the configuration file of the phone?

Best regards!
LVL 7
matrix8086Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KimputerCommented:
Just a quick answer though I do not use either Elastix or a Grandstream.

Best guess (takes you just a few seconds to check) is it's done through TFTP (which usually serves files based on MAC address).
Look through the TFTP data directory '/tftpboot
Or look through the TFTP logging is to syslog ("/var/log/messages")
If you find nothing there, it's probably somewhere served through HTTP and I hope someone else can then answer this question.
0
matrix8086Author Commented:
The problem was in the file /usr/share/elastix/endpoint-classes/class/elastix/vendor/Grandstream.py where the default language was 'es'/ I've modified to 'en' and the problem disappears. The config file is build with the settings from "Vendor".py
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
matrix8086Author Commented:
This really solved my problem. I have searched a lot to find the answers and I found about this file in some forum where the discussion it was about the TimeZone, but I said let's check this file and it's worked
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.