How to setup freepbx distro to send and receive fax

Hi experts,
I spent the  weekend installing freepbx distro on a server. I am using 2 rhino cards. One that has 2 pri input and one that has a mix of FXO and FXS modules.  I was using Trixbox but it was time to upgrade to a newer version.
I did a fresh install and everything works perfectly besides the fax.
My fax number are coming thru my pri  and I setup each of my fax machine to a separate extension with a dedicated DID number ,
When I try to send or receive a fax the line ring , the fax machine picks up and does it's weird noise then it seems to connect but the fax fail every single time.
I am really not sure what else I am supposed to change in order to have a clean fax coming in.
On my trixbox system I didn't have any issue sending fax.

Can someone help me figuring out my issue ?
Thank you ,
David
tavernyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Duncan RoeSoftware DeveloperCommented:
The fax machine is trying to negotiate a serial connection. The noise it makes is because it starts at a really low baud rate and potentially works up to a very high one.
It has to have an 8-bit clean line to do this. Are you sure that's what you're giving it?
0
tavernyAuthor Commented:
Thank you for your response and sorry for my late response , I haven't got the chance to play with it again. I will probably try it again during next week.
0
tavernyAuthor Commented:
Hi ,
I am back again this weekend to figure out the issue with my faxes.
here is what I have done.

I have a trixbox server that works fine with my Rhino R24FXX , I removed the Hard drive and did a full installation of FreePBX Distro on a new drive on the same server. Everything works fine (PRI doesn't have any issues) but for some reason the fax are still not working.

I removed the drive , reconnected the drive from my trixbox and faxes are working.

so I know the cards are connected properly.
I removed trixbox drive , and reinserted my freepbx drive , fax doesn't work.
here is what's happening when trying to send/receive a fax:
the number dial the other fax machine , the machine picks up , I can hear the negotiating noise , and then the fax hangup . it seems that the faxes don't understand each others.

I tried to send a fax from both directions and also by dialing extension so I bypass my provider in case the issue was coming from the provider.
I also plug a phone into the fax line and called it and I can hear and talk properly.

I am really lost on what I should look in order to fix that issue. is there a configuration or something that needs to be enable in order to have fax working?

Thanks for your reply.
David
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Duncan RoeSoftware DeveloperCommented:
Really really check that line is 8-bit clean.
After that, I am out of ideas: you might like to Request Attention and have the mods send out a call to more experts
0
tavernyAuthor Commented:
Duncan,
How can I check that?
0
Duncan RoeSoftware DeveloperCommented:
Check the line settings when the modem is attached by, as root, the command stty -F /dev/ttyS0 -a (assuming it is using ttyS0 - change to whatever device is right).
Ensure the output contains -parenbcs8 (8 bits, no parity). Also ensure -inlcr -igncr -icrnl -olcuc -ocrnl -onlcr -onocr -onlret -ofill -ofdel -icanon

Or if you like, just post the output and I'll check it.

I was thinking, if that isn't the problem then it might possibly be a difference in the AT commands that the different software packages send to the fax. You can't manually send fax AT commands because they have to be delivered in a timely manner. I did find a package that would monitor serial line traffic once - at work - can send you details if you would like to try it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tavernyAuthor Commented:
Hi ,
I finally resolved the issue. I ordered a new card from Rhino equipment and tried it again and I had the same issue. so I called tech support of Rhino and they logged in the machine and figured out the issues.
The card has an echo canceler built in , when installing the cad from the gui the freepbx software doesn't turn on the hardware echo but the software echo and that creates an issue with fax transmission.
so here are the step from the vendor:


1-Edit file /etc/dahdi/system.conf (replace oslec with hwec) save file.
2-Run "dahdi_cfg -vvv" (should show you the output with channels info)
3-Restart asterisk , run "amportal restart"

If you setup the card using the web tool , it will reset all configurations, then you need to follow step1-3.

Thank you for your help on this issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.