Azure - Port Forwarding

Hi Azure Experts

I'm trying to set up Port Forwarding and it isn't working very well. I want port 25565 to be available from public internet.

I have setup the Endpoint in the VM:
1.PNGI have created this Endpoint while the VM was powered off. Booted up the VM and added port 25565 to the Windows Firewall Inbound Rules but I'm getting "Port 25565 is closed on MYEXTERNALIP" when using http://www.yougetsignal.com/tools/open-ports/ - its worth nothing that if I test the Remote Desktop port it on the same YouGetSignal site it says its open.

I have put the VM into my one Network on Azure.

Any suggestions would be great.
LVL 13
Mark GalvinManaging Director / Principal ConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
as mentioned in http://www.experts-exchange.com/questions/28711935/Azure-Automation-Shutdown-of-VM.html#a40968903   an instance level pubic ip makes your vm responsible for firewall.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mark GalvinManaging Director / Principal ConsultantAuthor Commented:
Hi again

I have managed to setup the ILPIP and ReservedIP. The AzureService has that IP and the VM is under that Service. I can shut down the VM and bring it back and it keeps using the same ILPIP.

The Endpoints have been setup as follows:
60088 - RDP: Works fine
5986- PowerShell: Works fine
25565 - My App: http://www.yougetsignal.com/tools/open-ports/ still reports the port as not being open!!!

I have added that port to the firewall on the VM

Any ideas?

Thanks
Mark
0
Mark GalvinManaging Director / Principal ConsultantAuthor Commented:
As a test i disable the Windows OS Firewall and yougetsignal is still reporting that 25565 is still not open.
0
Mark GalvinManaging Director / Principal ConsultantAuthor Commented:
Hi

Ignore

Sorted it. It was the Windows Firewall rule not being correct!!

Thanks
Mark
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Azure

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.