Remote desktop won't work through Sonicwall TZ200

Hello Experts,

I am trying to enable remote desktop for a windows server that is being the Sonicwall. I have added it as an address object, created WAN to LAN access rule and a NAT Policy as well. Still its not getting through. Please help.

Thanks
LVL 1
NishantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NetExpert Network Solutions Pte LtdTechnical SpecialistCommented:
0
NishantAuthor Commented:
I followed the same link while setting it up. It doesn't work for me.
0
NetExpert Network Solutions Pte LtdTechnical SpecialistCommented:
OK.

Did you check the sonicwall logs for the connection iniated from outside client to server.

Do you able to do Remote Desktop locally to the server?

Just try "telnet (server public ip) 3389" from the client machine and look for the connection logs in sonicwall
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

carlmdCommented:
Any chance you have the same ip subnet at the pc you are rdp from, and the one you are rdp to?
For example, both at 192.168.1.x
0
Blue Street TechLast KnightCommented:
Hi nishantdewan86,

I see many people having issues with opening ports on their firewall because they mis-configure the Access Rules by assigning objects incorrectly in the Zones or by mis-configuring NAT and thinking its a security mechanism so they essentially don't setup the policy correctly regarding flow or its too restrictive. Remove what you did and just use the Public Server Wizard to quickly configure your SonicWALL to provide public access to an internal server buy clicking the Wizards link. The Public Server Wizard is the most ambitious and functional wizard developed to date. It simplifies the complex process of creating a publicly and internally accessible server resource by automating above mentioned steps.

It is not a security best practice to open up RDP publicly.

Regarding RDP, I'd recommend one of these options below for security reasons:
a) Setup MSFT RDS Gateway on a server so that traffic in is coming on 443. It will also allow you to control and provide counter measures for unintended access; or
b) Leave RDP off externally and setup a VPN (GVC or SSL-VPN) so external users have to VPN first then RDP to whatever resource then need thereafter.

Let us know how it goes!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Blue Street TechLast KnightCommented:
Thanks for the points...glad I could help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.