PSHED.DLL file Missing or Corrupt black screen on server 2008 R2

I'm trying to preserve the integrity of the application and data on this server and not perform an OS repair.  I'm able to boot into the server with a WinPE disk and access the files.   When I initially go access to the 2008 R2 OS, the pshed.dll files were missing from the server.  I found another Win 2008 R2 install and copied the psched.dll files from there to the problematic server but I'm still receiving the, "PSHED.DLL file is missing or corrupt" error.    Is there any method I can use to repair this dll?   The server will not boot.  I can only access the OS via the WinPE disk.  Thank you.
T110E5Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
Booting using install media and enterin restore console?
Did this issue start following an update?
You may have to boot using windows media and get into the restore to go back one restore level.
One option to try to boot using last good configuration if not attempted.

Can you boot into safe mode or you get the same missing dll error?
T110E5Author Commented:
The server did not appear to have received and update.  It had not been rebooted.  IThe server would not accept logins.   So, I rebooted to attempt to clear the issue and that's when the dll error occurred.    I've tried "Last Known" and it did not work.   Attempting to boot into safe mode results in same error.   I will try recovery media but will have to find drivers for the HBAs since this server is boot from SAN.   I was hoping there was a repair utility that I could copy over and attempt a repair on the PSHED.DLL files using the WinPE disk.
arnoldCommented:
If it boots from SAN, where did you place the pshed.dll?
Are you able to access the SAN LUN from which it boots and make sure the pshed.dll is there(make sure the server is not accessing it)?

while it was copied, it might be reflected as foreign/locked.  Check file attributes.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Seth SimmonsSr. Systems AdministratorCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.