firewall suddenly refusing certain mail connections!?

Hi,

I've got a web form (on IIS) that sends an e-mail through our e-mail server once the data has been saved. This always worked just fine. But for some reason I'm not getting this error:

No connection could be made because the target machine actively refused it xxx.xxx.xxx.xxx:25

But I don't see anything on the traffic monitor of the firewall (Watchguard) when trying to send this message ...

Note: we can send our 'normal' e-mails and are also getting e-mails from outside, so there is no general e-mail problem with the firewall!

Any suggestions?

Thanks!

Jerome
XeronimoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joshua HopkinsPresidentCommented:
Is the mail server you are connecting to internal or external?  If it is internal make sure that the local system firewall is allowing those connections.  If external you will need to do the same.  Is the form/page on your IIS server using authentication to send the email?

I have found that typically most email server are requiring email to sent via the submission port 587.

You could also try to telnet from the IIS server to the mail relay on port 25 and send a test email.  There is some good information here on how to test.
0
XeronimoAuthor Commented:
I can telnet the mail server from the outside, so that works ...
0
Joshua HopkinsPresidentCommented:
Can you send a message via the telent?  An example command would be:

Telnet mailserver.com 25
EHLO yourdomain.com
MAIL FROM:Admin@yourdomain.com
RCPT TO: user@whereyourappsendsto.com
DATA
Subject: test message
This is a test message you will not see a response from this command
.
Quit

Open in new window

You do need the period on the line by itself to close the data command.
0
XeronimoAuthor Commented:
D'oh ... the problem was the McAfee program running on the web server ... it got reconfigured without my knowledge and that disabled the communication between the web and the mail server. Everything working fine again now!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
XeronimoAuthor Commented:
This solved the problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.