Connecting to an Unsecured Guest Network

I have a Cisco 5500 Controller on my Network. It handles many wireless networks mostly secured with SSIDs.  I have a unsecured Guest Network which broadcasts and a DHCP server that gives IP address.  It's on a seperate VLAN.  All phones android and Iphones and even Kindles connect without a problem.  However, I'm trying to connect laptops and that's where the problem lies.  If I connect the laptop to one of the secured networks it connects 123 without a problem.  It's when I try to connect to the Guest Network that I can't connect I'm only getting a 169 address no internet and the Adapter reads unidentified network.  I've tried reinstalling the driver, rebooting, diabling the card etc.  I can't connect.
WellingtonISAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Wayne88Commented:
Is this problem uniform to all laptops or just one?  We had a problem with one laptop that keeps dropping out of the network with other connectivity issues.  It turned out that it was only this one laptop, probably bad/faulty WiFi nic.  Another laptop (similar make and model) was fine.
0
WellingtonISAuthor Commented:
It's a problem with most of the laptops and I'm able to connect to any secured network with an SSID without a problem.
0
Wayne88Commented:
Sounds like it's due to the software installed on the laptop that's causing it.  It's definitely not a hardware issue if most laptops are having that problem while mobile devices don't.  Have you tried turning off all security software (AV and endpoint, etc.)?  It's probably best to try with just bare Windows installed.
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

WellingtonISAuthor Commented:
OK that's an idea.  I'll try that and let you know.
0
Wayne88Commented:
Yes, now we must narrow down the problem.  Good luck!
0
WellingtonISAuthor Commented:
I uninstalled the virus software, rebooted and still the same result.  I'm only getting a 169 address.  Still no connection.
0
Wayne88Commented:
On the laptop, is DHCP enabled or is the address static? If static, there may be another device using that IP and conflicting.

Also, can you check the DHCP server to ensure that you have enough range for all the laptops?  If it's maxed out then there will be no more IP address to give out.  If your environment have many laptops coming and going then perhaps you may want to set a shorter dhcp lease time.
0
WellingtonISAuthor Commented:
No Static IP.  Plenty of IP's on the DHCP server there are about 2000.
0
djcanterCommented:
What is the ARP timeout in the layer3 switch or router? I have seen this issue where moving from 1 SSID to another will result in no new dhcp being offered from the new VLAN until the MAC ages out of the ARP table. maybe try a clear ARP in your layer 3 device after disconnecting and before joining guest wireless.
0
WellingtonISAuthor Commented:
I've requested that this question be deleted for the following reason:

Fixed this issue on my own and no one answered
0
Wayne88Commented:
Do you mind sharing the fix so that others who may run into similar problems may have some clues?
0
WellingtonISAuthor Commented:
Yes I was trying to use software to enable DHCP on a workstation instead of using it via the router.  It didn't work so I went back to using the router.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
WellingtonISAuthor Commented:
What I was trying to do didn't work out.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.