Enable Java, fire fox

Question: How do I enable FF to work with Java?

Background: I want to install jEdit (to study XML etc). jEdit requires java installed but first I need to enable FF.

The following image gives lots of options to read through and find out the right install. Please tell me which install will do what I want. Also, if possible give a brief description about the some or all remaining installs.EnableJava
LVL 34
Mike EghtebasDatabase and Application DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
java is a plugin not an addon
available from https://www.java.com/en/download/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CEHJCommented:
but first I need to enable FF.
Why? There's no connection between FF and jEdit
0
jcimarronCommented:
CEHJ--
" How do I enable FF to work with Java"
What do you mean by" enable" other than just installing?
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Sudeep SharmaTechnical DesignerCommented:
CEHJ,

First you need to download and install JRE on your computer. So go to the link 1 below and download the JRE on your OS.

By default in Firefox, if you see the installed plugins/add-ons, on the Java/JRE addon you would see that it is configure to "Ask to Activate" by that it means that everytime you are opening anything which needs Java it would prompt you and you have choose whether you want to run it.
"Always Activate" option on JRE/Java would not be available in this add-ons window, it would be grayed out.

Now there is a way to make it enable as well, however you have to be aware that it would be  very big security threat and you make sure that you know what you are opening.
So that fix is, that you open a new tab in firefox and type about:config and hit enter.
Click on I’ll be careful prompt.
Search for extensions.blocklist.enabled
Double click on it and make is false.
 Then go back to the addons and now you can make Java/JRE to "Always Activate".

I hope that would fix the issue with jEdit.

Sudeep


Link 1:
http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html
0
CEHJCommented:
CEHJ,

First you need to download and install JRE on your computer.

Firstly, why does everyone keep addressing me? I didn't ask the question ;)
Secondly, if you're going to be doing Java development with jEdit, your first thought should be to install a JDK, not a JRE.
http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
0
Mike EghtebasDatabase and Application DeveloperAuthor Commented:
my apology for the delay. I will respond shortly.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.