access ASDM on cisco asa 5505

Rajkumar Kamath
Rajkumar Kamath used Ask the Experts™
on
Good Day,

I have asa 5505 on which i would like to access asdm. when i try https://x.x.x.x , it doesnt launch asdm , however it goes and prompts me to enter username and password

i can do telnet to asa from one of the server machines which i have allowed on the asa. login to enable mode and do whatever changes required.

i have http enable
           http 0.0.0.0 0.0.0.0 inside

on the asa , when i do sh run.

apart from that not sure what else to. it used to work before. appreciate assistance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2015

Commented:
while its prompting username password, you need to provide username and password.

Once the password is right, you can see an option to download ASDM

checkout this url for more info

https://supportforums.cisco.com/document/102461/how-access-cisco-asa-using-asdm
Rajkumar KamathIT Manager

Author

Commented:
how can i check what username its asking for. i know both login and enable password to login to asa.

thanks
Top Expert 2015

Commented:
you can provide the same username which you are using for telnet access.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Rajkumar KamathIT Manager

Author

Commented:
there is no user. all i get is prompt for passwords and thats it. last time , we had disabled no transport input all. not sure if that has got anything to do with it,tried creating a user with priv 15 level. it still doesnt login and shows invalid login .

thanks
Top Expert 2015

Commented:
can you run the below command in ASA and paste the output here

#sh run | i http
#sh run | i username
#sh run | i enable
#dir
Rajkumar KamathIT Manager

Author

Commented:
sh run
----------
 port-object eq https
access-list outside-in extended permit tcp any host 83.xxx.xx.xxx eq https
http server enable
http 0.0.0.0 0.0.0.0 inside
 group-url https://83.xxx.xx.yyy/anyconnect enable\


sh enable
-------------
enable password 6R0pKvAZdKXDZYJ8 encrypted
logging enable
no asdm history enable
http server enable
crypto isakmp enable outside
crypto isakmp enable inside
crypto isakmp enable inside2
dhcpd enable inside2
 enable outside
 enable inside
 enable inside2
 svc enable
 group-alias VPN enable
 group-alias anyconnect enable
 group-url https://83.xxx.xxxx.xxx/anyconnect enable

sh user
----------

username "user" password GdjlykRzleZgWT/i encrypted privilege 15
username "user" attributes
Top Expert 2015

Commented:
all the required options are configured on the ASA. the config looks OK

while you type https://<asa inside ip>.  username "user" should accept
Head of IT Security Division
Top Expert 2010
Commented:
I think you missed the asdm image

you need this one:
asdm image disk0:/asdm-731-101.bin

Open in new window


please replece the image name to your device asdm image. you can find with dir command:

asa-hess3# dir
144    -rwx  19884888     11:03:40 Nov 19 2014  asdm-731-101.bin

Open in new window

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial