Ethernet Port not working on Notebook

Hello, I have a customer's Compaq notebook, Windows 8.1, and there is a problem with the Realtek FE Family ethernet controller.

It just won't configure itself with DHCP. WIFI works perfectly instead.

Screenshot of properties
Here's what I have already tried:
changing the cable
changing the port on the router
changing the router
resetting winsock
resetting tcp/ip
removing the driver and installing the latest version
ipconfig /release
ipconfig /renew

When I try resetting tcp/ip, it gives an error where it says "access denied" but it doesn't specify the component the error is related to.

So can somebody help me out? Faulty port maybe?
Daniele BrunengoIT Consultant, Web DesignerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

IT-ExpertCommented:
When you say "removing the driver and installing the latest version", how did you do this?
I ask because I was thinking of deleting the network adapter in Device Manager (and either refreshing the view), or restarting the PC and letting it detect and pick up the network port again.
The fact that WiFi is ok would definitely suggest that it's something to do with the actual cable port.

Another suggestion is to try manual assigning an IP address to the adapter?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeCommented:
For a test, deactivate IPv6. If no better, boot a live system (windows2go or knoppix) and test there.
0
Daniele BrunengoIT Consultant, Web DesignerAuthor Commented:
@IT-Expert: I have tried just that, deleted it. On reboot it downloaded the driver but nothing changed. I then uninstalled anything Realtek related and downloaded an updated driver from Realtek, nothing again.

I have not tried manual IP, mostly because my customer needs Dhcp to work.

@McKnife: I will try both and report.
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

nader alkahtaniNetwork EngineerCommented:
this image show our there is :
1.DHCP client is configured to get IP from DHCP server
2.it couldn't get the IP
disable WIFI then try again then unplug the cable and plug again ... you should see the network icon in the right corner in the laptop .
if no help , try to ping DHCP server from the client laptop , if it reply then there is some problem related to dhcp client or server
you may need to clear the IP pool cash from server side
0
Phil Stuart-DouekApplications SpecialistCommented:
The fact that you have a 169 ip address suggests that it is  a network problem rather than a local problem.

I would assign a manual ip address to start with to test the network port, and once you have confirmed that it  is, or isnt working then you can go on to look elsewhere.

My guess would be there is an issue with the DCHP server - do other machines gain ip's from plugging into the same port?
0
Daniele BrunengoIT Consultant, Web DesignerAuthor Commented:
The dhcp server is configured on my Mikrotik router and works fine with more than 15 devices I have hooked up right now.

I have already tried disabling Wifi but nothing changed. I will try to boot a Live cd since disabling IPv6 didn't work either.
0
nader alkahtaniNetwork EngineerCommented:
Try to use static IP on that notebook for troubleshooting purpose  ping the DHCP server did it reply?
0
Daniele BrunengoIT Consultant, Web DesignerAuthor Commented:
I just noticed that the Mac Address in the screenshot I posted is a sequence of twelve 0s.

Also, I booted with Lubuntu and it sees the Mac Address the same way and there is no connection either, so I guess it's the ethernet card after all.
0
nader alkahtaniNetwork EngineerCommented:
The nic may damaged or incompatible
1
nader alkahtaniNetwork EngineerCommented:
Thanks,   but what was the source of the problem?
0
Daniele BrunengoIT Consultant, Web DesignerAuthor Commented:
As you said, damaged nic, there's no other explanation. It wont' work with DHCP, fixed IP, different routers on different networks, different OSes.

Since there was no real solution, I gave points to all the people who tried to help.
0
nader alkahtaniNetwork EngineerCommented:
Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.