SBS 2011 Exchange 2010

Lewis
Lewis used Ask the Experts™
on
Hi I'm currently running SBS 2011 with exchange and SQL I need to limit exchange to 10GB as its not giving up the ram to the SQL. I looked on line and set the sizes as it suggested but then my exchange only runs with 1GB I think I'm putting the wrong amount in this is what I put in max 327680 and min 307200. could someone please tell me if this is correct?

Thanks

Lewis
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2015

Commented:
Are you running Exchange and SQL on same server?

This is really not supported.

However article is here to limit Exchange server, but not sure about pros and cons. Because if Information Store service will not have enough memory to run on required memory then it can crash at any point of time.
LewisNetworking

Author

Commented:
yes I am aware of this and explained to the client but I'm just trying to give them a work around until they sort this out. there old providers sold them SBS as it was a lot cheaper than having  separate exchange and SQL server. so just to be clear I need to set the max to (10GB 327680). this is the figure I put in and it wouldn't let exchange go over 1GB causing the server to crash.

thanks
Top Expert 2015

Commented:
not sure if you did in same way:

1. Stopping all Exchange services
2. Changing attribute through ADSIedit.msc (msExchESEParamCacheSizeMin = 196608 and msExchESEParamCacheSizeMax = 327680).
3. replicate AD
4. restart Exchange server and check.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

LewisNetworking

Author

Commented:
that's what I done on the server but doesn't seem to work I have had a look around and seems its a known problem


SBS2011 server without any setting will after it has been running for a few hours be using 95-98% of available memory. This box has 20GB RAM
 Set min cache at 65536 (2GB) and max at 262144 (8GB) and restart the store. Some days later sever is only using 65% of physical memory with the store using 2GB of physical and 4GB of virtual – and the disk I/O significantly higher than prior to setting this.
 So setting this to “improve” the responsiveness of the SBS box has had little impact and instead of using the Max setting, the store is only using the min setting that has been defined.
Top Expert 2015
Commented:
Then define minimum same as maximum.
LewisNetworking

Author

Commented:
Thanks for the Help

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial