Red Hat Printing Tray Definition

We have an application running on RedHat rhel5 that requires some significant volumes of printing to Ricoh (MP4000, b/w) Multifunction Devices with 4 trays, for different stationery types.
Trays 1-4
1.            A4 Plain
2.            A4 Bill
3.            A4 Survey
4.            A4 Letterhead

We are using CUPS with Ricoh Aficio MP 4000 PXL printer drivers.  On submitting the job – e.g.

Examples:
#>more <filename> | lp –d<printername> -oInputSlot=3Tray
#> lp –d<printername> -oInputSlot=4Tray <filename>

<printername> = “3rd_Floor” or “dept” (as per CUPS reference)


The result of this is correct text but paper sucked from tray 1 (plain) when should be tray X (as specified )…………..
The Live environment works perfectly, so can discount printer, database engine, and..
..Main s/w Application is not at fault as these test are performed outside of it using Putty/terminal with same – negative – results
ppd (printer defs) files are exactly same on each environment too
007JBAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wyliecoyoteukCommented:
Have you specified the media type on the MFD?
If so, you will also need to specify it when printing or it will default to the plain paper tray.
0
007JBAuthor Commented:
Thanks - yes.  We have specified the media type on the MFD itself.  We have our Live Redhat box which detects correct stationery and prints jobs correctly.  Our Test server printing to the same MFD, the same print job does not.  On the face of it both servers have the same settings defined for the printer, but there must be another setting buried somewhere?
0
wyliecoyoteukCommented:
Check that they are both running the same version of LPD.
Not all support -o and will just ignore it.
And I think that there should be a space after the -o as in:
-o InputSlot=4Tray <filename>
0
007JBAuthor Commented:
On Test:
CUPS : 32.el5_11
Ghostscript : 8.70 (15.el5_9.3)
Perl : 5.8.8 (43.el5_11)

On Live:
CUPS: 30.el5_9.3
Ghostscript : 8.70 (14.el5_8.1)
Perl : 5.8.8 (40.el5_9)

We have downgraded the Ghostscript (8.70 (14.el5_8.1)) and Perl (5.8.8 (40.el5_9)) installations to match that of LIVE and tried our tests again.
This time is was successful
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
007JBAuthor Commented:
Solved ourselves
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.