Keyboard taking on a mind of its own

Dell Inspiron 15, 3000 series.  My laptop has suddenly started acting strangely. I may be typing, when suddenly when I press a key (say the key 's') instead of typing the letter 's' the screen changes to Settings. When I press other keys the screen changes to other applications. In other words from simply typing letters, the keys change their function.
Only change made which might have something to do with this: a change of location, from Europe to America.  Remedy: when I restart system the problem stops. But this does not always work.
Another strange thing? When I access this website the items on the screen become greatly magnified - letters, symbols, everything.
Michael MurphyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Wayne88Commented:
Verify that there are no stuck keys because that's what it sounds like.

You can go here to test the keyboard: http://www.keyboardtester.com/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Brian BEE Topic Advisor, Independant Technology ProfessionalCommented:
Most likely your alt or ctrl key is sticking. When it start happening again, hit those keys a few times each and see if the problem stops. If you get a windows "sticky key" prompt, just cancel it.
rindiCommented:
Besides having a stuck key, also check your "Ease of Access" options, you may have enabled some of those.
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Michael MurphyAuthor Commented:
1. How do I return the display to default settings. As things stand everything is enormous. When I opened 'Ease of Access Center', there was nothing obviously awry. When I started the Magnifier it only made the display even bigger.

2. I managed to open the Tester. It showed the keyboard. But what am I to do next. How do I test it? I could see no instructions
Wayne88Commented:
1. Go to the control panel > display then choose adjust resolution and adjust accordingly to your liking.

2. Start hitting every key on the keyboard to test.  If there is a stuck key then you won't see it type or it will type repeatedly.
Michael MurphyAuthor Commented:
Thanks. What of the Ctrl, Fn and Alt keys? If there is a click when I depress them am I to take it that they are working.

With regard to the other problem, when I open my browser (I have Internet Edge and Firefox) the search page is normal. But when the item searched for is found it displays in very large sizes. I opened control panel and 'display', and the 'change size' option, but nothing made any difference - everything seemed normal - and there does not seem to be a 'return to default settings' option.
Wayne88Commented:
In your IE or Firefox there should be a zoom function.  In IE, hit Alt+F then set the zoom to 100%.  You probably have it bigger than that.

For the ctrl and alt key you should see it lit up when you hit them.  That's all.
Michael MurphyAuthor Commented:
I found how to ask St the zoom in Microsoft edge browser Cyril key depressed roll the wheel on external mouse
Wayne88Commented:
eenookami-Admin, who are EamonX1 and TBone2K .  They are not a part of this thread.  If this is regarding another thread then please post in that thread.  It doesn't make sense to post here.
Michael MurphyAuthor Commented:
All three experts helped  in the solution. .  In fact there were two question instead of one. I added on a second q in my first post, which I should not have done.  See last sentence 'Another strange thing ....'

Wayne 88 and Brian B provided clues to solving the first question. And Rindi did also with his mention of 'sticky' keys. So all three deserve marks for this.
 Wayne 88 pointed me in the right direction with regard to the second question (that it had to do with the Zoom feature). I found out the importance of using the external mouse wheel myself, having held down the Ctrl key.

Can you allow me to award the points and I will do it as I should have done it in the first place. Excuse for not doing it in the first place: none really apart from old age and pressure and they are not to be given intoi
Brian BEE Topic Advisor, Independant Technology ProfessionalCommented:
I am TBone2K. That is my username, which doesn't show depending on what you are using to view the site. Anyways, if the mods would reopen the question, we'd appreciate you taking the time to use the multiple solutions choice to flag all the answers you thought were helpful.
Wayne88Commented:
Ok thanks for the explanation, sorry for my misunderstanding.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Word

From novice to tech pro — start learning today.