Vm instance keeps losing time

Hello EE,

I have a 2012 r2 web server vm instance running in a vmware environment . The server is in a dmz and uses ntp to synchronize  . Strangely, the server will consistently "lose time" , the time will be off by 20 mins . I checked the time-service event sand see  event 36 only as a warning event. Previously, I used time.nist.gov as a synch source but changed to time-a.nist.gov . Is there maybe something with the time on the underlying hardware of the vm ?



C:\Windows\system32>W32TM /query /status
Leap Indicator: 0(no warning)
Stratum: 2 (secondary reference - syncd by (S)NTP)
Precision: -6 (15.625ms per tick)
Root Delay: 0.0312707s
Root Dispersion: 7.7756253s
ReferenceId: 0x81060F1C (source IP:  129.6.15.28)
Last Successful Sync Time: 9/10/2015 2:52:51 PM
Source: time-a.nist.gov,0x9
Poll Interval: 10 (1024s)
davesnbAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
this is not syncing with the host via VMware Tools ?
0
Wayne88Commented:
I've came across this problem before.  The VM is getting the time from the host (ESX).  You need to synchronize the time on the ESX.  I believe there is a function to sync the host and client time somewhere.

Configure Time Synchronization Between Guest and Host Operating Systems

Synchronize the Time by Using the vSphere Web Client
0
davesnbAuthor Commented:
so if I understand correctly , I should disable the timesync with the host system using the vmware tools to not reference the host time which is likely outside of the offset. This will  allow for the independent time keeping on the guest instance using ntp. If that is the case wha ti sthe actual command , i tried searching in the directory as detailed below with no luck.

utility-name timesync subcommand
For subcommand, use enable or disable.



01/16/2015  06:22 PM    <DIR>          .
01/16/2015  06:22 PM    <DIR>          ..
09/01/2014  05:46 AM           870,104 deployPkg.dll
09/01/2014  05:47 AM           670,936 gio-2.0.dll
09/01/2014  05:47 AM         1,302,744 glib-2.0.dll
09/01/2014  05:47 AM           781,528 glibmm-2.4.dll
09/01/2014  05:47 AM            26,328 gmodule-2.0.dll
09/01/2014  05:46 AM           355,032 gobject-2.0.dll
09/01/2014  05:47 AM            36,568 gthread-2.0.dll
09/01/2014  05:46 AM           107,224 hgfs.dll
09/01/2014  05:46 AM         1,180,888 iconv.dll
09/01/2014  05:46 AM         9,609,648 icudt44l.dat
09/01/2014  05:47 AM           114,904 intl.dll
01/16/2015  06:22 PM    <DIR>          messages
09/01/2014  05:46 AM         1,267,472 open_source_licenses.txt
01/16/2015  06:22 PM    <DIR>          plugins
09/01/2014  05:46 AM               280 poweroff-vm-default.bat
09/01/2014  05:46 AM               280 poweron-vm-default.bat
09/01/2014  05:46 AM               457 resume-vm-default.bat
09/01/2014  05:47 AM           113,368 rpctool.exe
09/01/2014  05:47 AM            77,824 sigc-2.0.dll
09/01/2014  05:46 AM               459 suspend-vm-default.bat
09/01/2014  05:46 AM            14,194 vm-support.vbs
01/16/2015  06:22 PM    <DIR>          vmStatsProvider
09/01/2014  05:47 AM           744,664 vmtools.dll
09/01/2014  05:46 AM            74,456 vmtoolsd.exe
09/01/2014  05:47 AM           237,272 VMToolsHook.dll
09/01/2014  05:46 AM           309,464 VMToolsHook64.dll
09/01/2014  05:46 AM            17,112 VMToolsHookProc.exe
09/01/2014  05:56 AM             1,184 VmUpgradeHelper.bat
09/01/2014  05:46 AM            81,624 VMwareHostOpen.exe
09/01/2014  05:47 AM            52,440 VMwareResolutionSet.exe
09/01/2014  05:47 AM            41,176 VMwareToolboxCmd.exe
09/01/2014  05:47 AM           148,184 VMwareXferlogs.exe
01/16/2015  06:22 PM    <DIR>          win32
01/16/2015  06:22 PM    <DIR>          win64
09/01/2014  05:46 AM           143,064 zip.exe
              30 File(s)     18,380,878 bytes
               7 Dir(s)   5,528,969,216 bytes free
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

frankhelkCommented:
That's correct. Disable the VM from syncing with the Host and stay with NTP.

Currently the VM is using two timekeeping services concurrently, which inevitably leads to strange time behaviour and effects.

I would further recommend to use the servers at pool.ntp.org for reference. That way you'd have more redundance in the time sources. See my article on NTP for more information.
0
davesnbAuthor Commented:
Ok great, and thanks for the information on ntp . Can you please provide the command in question for disabling the time synch for vmware tools ?
0
Wayne88Commented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
davesnbAuthor Commented:
Excellent thanks
0
Wayne88Commented:
You're welcome. Cheers!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.