Remote Desktop Automatic Startup Issue

Ok, here is my situation. At my company, we have several mobile users who use laptops to remotely connect to one of our servers via our local Wifi network. We are using Microsoft Remote Desktop. We have the laptops configured through Group Policy so that at bootup, they automatically log in to the local user, start the remote desktop application, and log onto the server using our network credentials. This process works seamlessly....until I reboot. The issue I am having is upon first startup, the unit will boot, login to the local account, start RDP, and login to the server without issue. Then, if the unit is rebooted, it will login to the local acocunt, start RDP, then return an error saying that it cannot find the target computer. However, if the unit is then immediately rebooted a second time, it does not give an error and the process will work. This happens without fail EVERY OTHER time the unit is rebooted. First time it works, after reboot it fails, reboot again and it works, reboot it fails. Every time. I have tried configuring static DNS, adding the server to the hosts file, disabling firewalls, everything I can think of. Has anyone ever seen this before?
RveiockAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Trent SmithCommented:
I have never seen this but I would suggest looking at the logs and seeing what the issue is.  Is the IP address static or DHCP?
RveiockAuthor Commented:
The laptop is configured with DHCP and the server has a static IP. I have checked the logs but can't find anything that seems to be related to the issue.
Trent SmithCommented:
Have you tried using a static IP address instead of DHCP?  Also use ipconfig /flushdns to get rid of everything that is old in the system.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

RveiockAuthor Commented:
Yes, I tried setting a static IP, however the issue still persists.
Trent SmithCommented:
Is this a wired or a wireless connection?
RveiockAuthor Commented:
It is a wireless connection.
RveiockAuthor Commented:
So far, everything we have tried has not resolved it. We have just decided to go with a wired connection. Even though this is less convenient, it is more efficient.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RveiockAuthor Commented:
Unable to resolve answer.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.