How to rate limit traffice on cisco router interface

So I have a 200Mbps internet circuit on my 2951 router. This is a burstable circuit meaning it can go faster than 200Mbps, but we get charged for anything over 200Mbps. I want to police traffic on the WAN interface so it can't go over 200Mbps. I would like to do this oubound and inbound. Below is my interface configuration: gi0/0 is my WAN interface

interface GigabitEthernet0/0
description TO_ISP_200Mbps
ip address x.x.x.26 255.255.255.248
ip access-group 110 in
duplex auto
speed auto
!
interface GigabitEthernet0/1
description TO_ASA_5520
ip address x.x.x..33 255.255.255.248
ip access-group 120 in
ip flow ingress
duplex auto
speed auto
!

If someone could email me a configuration it would be helpful.  Thanks.
LVL 4
denver218Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
You would need to configure qos, define the ........
A search for Cisco qos rate limit will provide the Cisco command reference.

Here is a support forum discussion that includes an example.  Note  the example is for 5m ..


https://supportforums.cisco.com/discussion/11692096/qos-rate-limiting


Which iOS version is on your router.

Cisco command reference ........ Rate-limit
http://www.cisco.com/c/en/us/td/docs/ios/12_2/qos/command/reference/fqos_r/qrfcmd8.html
denver218Author Commented:
So i've added the following.  For the outbound direction it works perfect, never goes over 200mbps.  Now inbound is a different story, its still high.  Now I'm thinking its because traffic is for example coming in at 400Mbps when it hits my WAN port and the router can't police it down that much to 200Mbps.  Any Idea?

policy-map LIMIT-BANDWIDTH
class class-default
  police 200000000 conform-action transmit  exceed-action drop


interface GigabitEthernet0/0
description PRIMARY WAN CIRCUIT
ip address x.x.x.x 255.255.255.248
ip access-group 120 in
no ip redirects
no ip proxy-arp
duplex full
speed 1000
service-policy input LIMIT-BANDWIDTH
service-policy output LIMIT-BANDWIDTH
arnoldCommented:
Your map is for transmit, you need a separate policy map for receive to handle the inbound traffic.

Is your burst pricing applied to both directions?

Another though, when packets reach your router, your dropping them or delivering to their destination count the same.

The bandwidth is already counted the packet whether you let it pass or not.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

denver218Author Commented:
Yes I understand in the inbound direction its already counted, but I wanted to police it anyway.  I thought the following applys to both inbound and outbound?

service-policy input LIMIT-BANDWIDTH
service-policy output LIMIT-BANDWIDTH
arnoldCommented:
You are applying to both, but the LIMIT-BANDWIDTH policy map is of transmit direction.

The difficulty whether the policy map applies and thepacketisdropped, not sure how you will determine it.

I.e. Match the inbound traffic on the outside interface and the outgoing on the LAN interface.
I.e. 250MB on the outside incoming, while during the same time there is only 200 on the inside outgoing.....

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
denver218Author Commented:
Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.