Unable to install driver for ASUS USB-N10 802.11n Wireless USB Adapter on Windows 7

Hi Experts,

I'm running Windows 7 64 bit.

I've plugged the unit in.

It appears in Device Manager as Other devices / 802.11n WLAN Adapter.

I've tried installing all 3 Drivers from the ASUS website: https://www.asus.com/us/Networking/USBN10/HelpDesk_Download/

Selecting OS: Windows 7 64 bit, there are 3 Items in the Wireless section:

1.  Version 1.0.0.18

            Dr_USB_N10_10018_Windows.zip

2.  Version 1086.38.1125.2010
      
            Driver_USB_N10_1086.zip

3.  Version 1.0

            Driver_USB_N10.zip

In all 3 cases:

a. I have extracted the files.

b. I have used Win7's Update Driver Software / Browse my computer for driver software and browsed to the Win7X64 folder.

c. I get the message: Windows could not find driver software for your device.

Regards,
Leigh
LVL 1
LeighWardleAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CompProbSolvCommented:
Looking at the site, the first driver should be the correct one.

Can you post the Hardware ID for the adapter from Device Manager?  I want to confirm that it is in the .inf file.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
WORKS2011Managed IT, Cyber Security, BackupCommented:
What happens if you download the "Utility" available in the same link you provided above.

ASUS USB-N10 Utility Version 1.0.0.18
OS Supported: Windows 2000/ XP(x86/x64)/ Vista(x86/x64)/ 7(x86/x64)

1. Driver updates for Windows and Linux
2. Fix WPS works abnormally
3. Fix the message of utility
4. Driver add support to MAC OS 10.7
CompProbSolvCommented:
The ID should start with USB\VID_
You'll find it if you right-click on the device in Device Manager, then Properties, Details, and select "Hardware Ids" in the Property drop-down.
Check Out How Miercom Evaluates Wi-Fi Security!

It's not just about Wi-Fi connectivity anymore. A wireless security breach can cost your business large amounts of time, trouble, and expense. Plus, hear first-hand from Miercom on how WatchGuard's Wi-Fi security stacks up against the competition plus a LIVE demo!

LeighWardleAuthor Commented:
CompProbSolv:

Does this give you the Hardware ID for the adapter from Device Manager?

Hardware ID for the adapter from Device Manager
LeighWardleAuthor Commented:
WORKS2011:

I downloaded the "Utility" available in the same link I provided above.
It failed to install the driver.
Erasmo Freire dos SantosSystem AnalystCommented:
Hello

Unpacks the zip files of drives and save on desktop

va in Control Panel \ All Control Panel Items | Device Manager

click Network Adapter Asus Right-click and choose

Update Driver software / Browse my computer fo drive software /

click the Browse button - Select Desktop - driver - click in next
UpdateDriver.jpg
ControlPanel-DeviceManager.jpg
LeighWardleAuthor Commented:
Thanks, erasmo freire.

I have already tried those steps for all 3 drivers, every time I get the message:
Windows could not find driver software for your device.

Regards,
Leigh
nobusCommented:
then i must conclude that either that driver is bad (contact Asus)
or the device is bad - and must be repalced
Erasmo Freire dos SantosSystem AnalystCommented:
Already tried to install the software DriverMax?

free software

link:

http://www.drivermax.com/download.htm
LeighWardleAuthor Commented:
Hi all,

Turns out that my actual adapter model name includes the word "Nano",
So it's the "USB-N10 Nano", and it's not the same as the  "USB-N10".

The "USB-N10 Nano" driver is on a different page (http://www.asus.com/Networking/USBN10_NANO/HelpDesk_Download/) to the one listed above.

I've installed the driver and now have Internet access.
LeighWardleAuthor Commented:
Thanks to CompProbSolv and WORKS2011 for helpful suggestions.

Cheers, Leigh
CompProbSolvCommented:
The hardware ID for your USB-WiFi adapter is USB\VID_0B05&PID_17BA.  If you look in the .inf file for the drivers you should find this mentioned.  It's not there in the net8192su.inf file in the Win7X64 folder for the Asus driver.  I searched for that hardware ID and found a driver at: http://sciencespaces.com/search/USB%5CVID_0B05--ds--PID_17BA/ .  There is one in there specifically for Windows 7 x64.  I've not dealt with this site before so can't vouch for the safety of it.

If you are willing to trust the site, I'd give that driver a shot.
LeighWardleAuthor Commented:
Hi CompProbSolv,

You missed the news that I found the correct driver (go up a few posts above).

Cheers,
Leigh
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.