outlook security prompt certificate name

with the removal of .local from SAN certificates we have updated our exchange 2007 virtual directories to point to farm.  but we are still getting the security prompt randomly appear.

 the prompt has the new certificate, but is showing the local cad servers

we have updated the owa,uc,web services virtual directories.

it looks like if we repair / rebuild the outlook profile or fixes the issue.

we have also just installed exchange 2013 servers.
Doug eAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MAS (MVE)EE Solution GuideCommented:
1
Shweta GoelCommented:
Hi,

This issue can occur if your Outlook client is connected to Autodiscover or Exchange Web Services on the new Exchange 2013 server that you have installed.
0
Doug eAuthor Commented:
Is there a way to stop users connecting to the exchange 2013 servers or are best to move all connections via the exchange 2013 until we can ckmplete the migration.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

MAS (MVE)EE Solution GuideCommented:
Domain added/Internal users will try to connect by SCP. so if Exchange2010 CAS is not available it will search for next available CAS server which is Exchange2013.  Please check this
0
Doug eAuthor Commented:
We finally found the issue after watching the network traffic and reviewing the Exchange configuration, to be with the Outlook client.  More importantly a little setting in Outlook 2013 which stops Outlook from rerunning Autodiscover unless outlook fails to connect.

In Outlook 2013 there is a new Autodiscover method used, called Last Known Good URL, this flag stops Outlook 2013 from rerunning the Autodiscover if the Last used URL is still good. In our case this was the problem as the CAS 2007 server CAS server was still contactable using the internal name that was originally listed on the Autodiscover.

To correct this we had to update a registry setting via a GPO

User Configuration > Preferences > Windows Settings > Registry > ExcludeLastKnownGoodURL

https://technet.microsoft.com/en-us/library/cc178992.aspx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Doug eAuthor Commented:
Issue was with Outlook 2013 client in the way it works with autodiscover
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.