Excel Ignoring Sort Command

I have been trying to sort a CSV with a million rows and about 20 columns in Excel 2013 (64bit). Excel doesn't seem even bother trying - it's simply ignoring the command as far as I can see. There's not even a spike in the CPU monitor on the Task Manager.

What could possibly be the reason for this?

PS: I'm using a HP ZBook 15 G2 (F1M34UT) Mobile Workstation: Windows 8.1 Pro, 32GB Memory, 1TB Samsung 850 EVO SSD, Intel Core i7 4810MQ (2.80 GHz) - Quad Core with NVIDIA Quadro K1100M graphics card. My colleague's far less powerful laptop (8GB RAM, Intel Dual Core) easily handles the sort on the same file.
mohknightAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

[ fanpages ]IT Services ConsultantCommented:
Does your colleague save the comma-separated values file as an MS-Excel workbook first, or is it still open in the ".csv" format?
0
mohknightAuthor Commented:
My colleague does it while the file is still open in the ".csv" format.

I have tried saving it to the ".xlsx" format and attempting a sort of all 1,000,000 rows - again the application ignores the command. I am able to sort around 500,000 - 620,000 (selected) rows though.

NOTE: Task Manager shows CPU monitor spikes to 17% and memory 21% during the sort of 500K rows so there's obviously a lot of resources left for 1000K rows.

Thanks!
0
aikimarkCommented:
1. Is it possible that there are 'gaps' in the data, resulting in empty rows?

2. Do you receive any messages when you open the CSV file?

3. Are you able to add a new row after you have opened the CSV file?
1
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

tomfarrarCommented:
After saving the .csv file as .xlsx file, change the data to a table Ctrl-T, and see if all the rows are being picked up.  Then use the table filters at the top and see if the sorting works.
1
mohknightAuthor Commented:
Hello Everyone,

I ran a repair on the installation and ran an update. That seems to have solved the problem.

Thanks for looking in and trying to help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
[ fanpages ]IT Services ConsultantCommented:
You're welcome.

Please close the question marking your more recent comment as the 'solution' if you resolved this yourself.
0
Martin LissOlder than dirtCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Excel

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.