Full Access to Exchange Mailbox in Exchange 2010

Hi,
I have noticed that sometimes when I give a user (eg User A) Full Access to another user's mailbox (User B), User B's mailbox AUTOMATICALLY appears in User A's Outlook. But sometimes it doesn't then I have to add it in manually.

How do I make sure that it does automatically appear. I have just granted 30 users full access to a mailbox but I don't want to visit every user to manually add the box nor confuse them with instructions for manually adding it. It would be better if the mailbox automatically appears for those 30 users
DonKwizoteAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MASEE Solution Guide - Technical Dept HeadCommented:
Are you running Exchnage2010SP3?  If you are running SP3 automatically it will appear in outlook.
Specially when you configure a new outlook profile full permission mailbox will appear automatic.
Scott CSenior EngineerCommented:
In addition to making sure you are on SP3, make sure you are on the latest Rollup Update.

http://www.microsoft.com/en-us/download/details.aspx?id=47676
systechadminConsultantCommented:
it automatically adds the mailbox, you can just ask the user to wait for 30 minutes or ask them to restart the outlook after sometime.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

AmitIT ArchitectCommented:
That's called Auto mapping feature. By default it will be enabled, when you add permission and shows up in user outlook too. You can check via adsiedit, if it is enable or not.

Check this
http://blogs.catapultsystems.com/drowe/archive/2013/02/08/automapping-mailboxes-in-exchange-2010-and-outlook-1/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DonKwizoteAuthor Commented:
Thanks Everyone. All your comments helped.
DonKwizoteAuthor Commented:
Thank you
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.