Dynamics 2011 SSRS Data Connector

I am trying to install an op-premise installation of Ms Dynamics 2011 for our development team. I have two boxes, one running SQL Server 2008R2, the other with the Dynamics 2011 Server (Updated to rollup 6).

We have an existing organisation (hence the old version of dynamics) which I am trying to import. The import wizard tells me that the CRM reporting extensions are not installed on the SSRS server. So I'm trying to install the CRM reporting extensions.

On the SQL server everything goes fine until the system checks when it tells me that (under the environment checks) that there is no such object on the server and the log file shows:

11:42:03|   Info| Group Microsoft SQL Server™
11:42:03|   Info| SQL Server Version: 10.50.6220.0
11:42:03|   Info| SQL Server Edition: 2
11:42:03|   Info| Check SqlServerValidator: Success
11:42:03|   Info| Check SqlInstanceNameValidator: Success
11:42:03|   Info| Check ConfigDatabaseExistsValidator: Success
11:42:03|Verbose| Retrieving config database version Provider=SQLOLEDB;Data Source=DEVDB;Initial Catalog=MSCRM_CONFIG;Connection Timeout=60;Integrated Security=SSPI ...
11:42:03|   Info| Config database version: 5.0.9690.4150.
11:42:03|   Info| Check ConfigurationDatabaseVersionValidator: Success
11:42:03|Verbose| Retrieving information from database Provider=SQLOLEDB;Data Source=DEVDB;Initial Catalog=MSCRM_CONFIG;Connection Timeout=60;Integrated Security=SSPI ...
11:42:03|   Info| PrivilegeUserGroup: CN=PrivUserGroup {ef03eab6-2f7a-43d5-8cb3-0765c1dcc7d5},<Domain path>
11:42:03|   Info| SqlAccessGroup: CN=SQLAccessGroup {ef03eab6-2f7a-43d5-8cb3-0765c1dcc7d5},<Domain path>
11:42:03|   Info| ReportingGroup: CN=ReportingGroup {ef03eab6-2f7a-43d5-8cb3-0765c1dcc7d5},<Domain path>
11:42:03|   Info| PrivReportingGroup: CN=PrivReportingGroup {ef03eab6-2f7a-43d5-8cb3-0765c1dcc7d5},<Domain path>
11:42:03|   Info| Check PrivReportingGroupActiveDirectoryRightsValidator: Success
11:42:03|   Info| Check CrmSqlDomainValidator: Success
11:42:03|   Info| Check ReportServerInstanceValidator: Success
11:42:03|   Info| Check CanPublishReportsValidator: Success
11:42:03|   Info| Group Environment Checks
11:42:03|   Info| Check ReportServerValidator: Success
11:42:03|   Info| Check ReportingAccountValidator: Success
11:42:03|Verbose| Retrieving information from database Provider=SQLOLEDB;Data Source=DEVDB;Initial Catalog=MSCRM_CONFIG;Connection Timeout=60;Integrated Security=SSPI ...
11:42:03|  Error| Check ReportingAccountMemberOfSecurityGroupValidator : Failure: There is no such object on the server.

Looking through google I can see other ReportingAccountMemberOfSecurityGroupValidator errors but not this specific one. I have tried the various solutions that have been presented for the other errors including adjusting permissions and editing the registry, but I'm still lost.

Some of the links I've looked at to help:
https://technet.microsoft.com/en-us/library/hh699807(v=crm.5).aspx
https://support.microsoft.com/en-us/kb/974584
http://error287.rssing.com/chan-5688711/all_p1.html


Can anyone point me in the right direction please? Any help gratefully received.

Thanks

Matt
Matthew AyersSenior Systems AdminstratorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Feridun KadirPrincipal ConsultantCommented:
Some random ideas - apologies if these are in the links you referenced, I did not review them:
- is reporting services configured and working?
- can you browse to http:// appropriate URL/reports?
- was reporting services installed in standard (I think that is the word) mode rather than SharePoint mode?
- Are all the groups referenced in the error log (with the GUIDs after the names) present in Active Directory and did you review the memberships?
- During the install of Reporting Extensions did you select the SQL instance in which CRM is installed?
- Are you logged on as a local administrator on the server and does the account also have admin rights to the SQL Server instance?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Matthew AyersSenior Systems AdminstratorAuthor Commented:
Thanks for this. In the end we decided to create a new account and started again with that.

I guess I must have missed something, but this time it worked. Using the questions above we formed a checklist.

Thanks for your help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Dynamics

From novice to tech pro — start learning today.