Can't Access Ports to Amazon EC2 Instance Even Though Defined in Security Group

I have an Amazon EC2 Windows 2008 R2 Instance created.  Attached to the Instance is a Security Group with the following rules:

*.- HTTPS : TCP / 443 / 0.0.0.0/0
*.- HTTPS : TCP / 443 / 0.0.0.0/0
*.- HTTP:   TCP / 80 / 0.0.0.0/0
*.- RDP:     TCP / 3389 / 0.0.0.0/0
*.- Custom TCP Rule: TCP / 8040 - 8041 / 0.0.0.0/0
*.- Custom TCP Rule: TCP / 5931 / 0.0.0.0/0

I also went into the Instance and opened the same ports in Windows Firewall (Advanced Settings) for all Zones.  In fact, at one point, I DISABLED THE WINDOWS FIREWALL.  

However, in each case (ports opened or Windows Firewall Disabled), I can't access some of the ports.  For example, port 80, 443, etc.

I used www.canyouseeme.org to test the ports to no avail and of course the applications (web server, etc) would not work.

I even created a new security group without success.

THE SAME SECURITY GROUP is used for another instance and it works great.  I've stopped the first instance and ONLY had the second instance running but still no luck.

Any thoughts would be most appreciated.
LCSLouisJJamesAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Stuart ScottAWS Content Lead at Cloud AcademyCommented:
Hi,

Without knowling how your instances are set up in your VPC, Public/Private subnets etc.  Please take a look a the article I wrote here that covers connectivity issues to EC2 instances.  It focusing on SSH and RDP, but the principles are the same as to why you may be having issues.  It covers a range of potential issues that you should work through to help identify where the issue is.

http://www.experts-exchange.com/articles/18564/Resolving-connectivity-problems-to-Amazon-Web-Services-AWS-EC2-instances-via-SSH-RDP.html

Cheers,

Stu...

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LCSLouisJJamesAuthor Commented:
Scott:

Firstly, color me stumped. I have good news and bad news?

When I went through your EXCELLENT GUIDE. everything was setup correctly.  It should have worked.  But I was getting failures. However, I believe I understand what happened.

I was using RDC to connect to the server. There I would test the ports (with the software installed) using sites like www.canyouseeme.org and www.yougetsignal.com. Each time the test failed and I was told the ports were closed.

However, running the application seem to suggest it was working.

ONCE I INSTALLED A DIFFERENT REMOTE CONNECTION SOFTWARE (like screenconnect) which allows me to remove to the desktop (and not like Terminal Services), those tests worked.

So in the essence, I was fooled into thinking the ports were closed.

In the end, success and thank you for your kind help.

Louis
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cloud Computing

From novice to tech pro — start learning today.