PrincipalContext.ValidateCredentials always returning false

Hello,

I have an application which uses DirectoryServices to validate an active directory username and password.  Up until the other day, it worked fine.  Now, the ValidateCredentials function of System.DirectoryServices.AccountManagement.PrincipalContext always returns false.  The application hasn't changed.  I don't believe there have been any infrastructure changes, except that the network did have a windows Certificate Authority which expired over the weekend.  Could this be the cause?  The network admins don't think the CA is tied to Active Directory authentication, but I don't know of anything else that has changed.  It is a Win2k8 R2 Domain.  Any ideas?  Thanks
Martin BertramAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SylvainDrapeauCommented:
You can take a look at this page : http://travisspencer.com/blog/2009/07/creating-users-that-work-with.html

In short, make sure userPrincipalName is the same as the account name and msDS-UserAccountDisabled is set to false.

Can you confirm that one account you are testing with has those two field correct as per the article ?

Just to eliminate a probable culprit.

Thanks !
0
Martin BertramAuthor Commented:
Thanks SylvainDrapeau.  Checked that out and it wasn't it.  Also this did work for many months up until a few days ago.
0
Martin BertramAuthor Commented:
It turns out this was being caused by our expired CA that was integrated with Active Directory.  After the network admins fixed the CA issue, the function worked normally again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Martin BertramAuthor Commented:
Found that the issue was related to a Certificate Authority installed in the network which had expired.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.