RDS 2012R2 with gateway and broker gives dual login prompt on XP

I have updated with SP3, the latest RDC client, and enabled the credssp update.
I download the shortcut from the RDWeb to double click on.
It works on Windows 7 or later, but on XP I get dual prompt on for password.
Is it possible to just have one prompt?
LVL 2
mathiesen-dataAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
That is one of the pitfalls with using an obsolete operating system. Policy here is once an o/s is no longer maintained by the manufacture it can no longer connect to our network
Cliff GaliherCommented:
The latest RDP client was never released for XP. Actually the last several weren't. And as such, there is no workaround. But since XP is dead and has known security holes, would you really want XP connecting to other machines anyways? It should not be run at all. But if you absolutely must, it should be totally isolated. No network traffic in or out.
StuartTechnical Architect - CloudCommented:
I agree with the previous comments RE XP

However I had a client with the same issues pre XP support end and this link helped me fix it for them - http://www.ervik.as/microsoft/windows-server-2008-r2/3321-how-to-configure-single-sign-on-for-remote-desktop-services

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mathiesen-dataAuthor Commented:
I used registry method.

Method 2 – Registry

 The group policy settings above correspond to the following registry entries:

Path: HKLM\SOFTWARE\Policies\Microsoft\Windows\Credentia lsDelegation
 Name: ConcatenateDefaults_AllowDefault
 Type: REG_DWORD
 Data: 1

 Name: AllowDefaultCredentials
 Type: REG_DWORD
 Data: 1

Path: HKLM\SOFTWARE\Policies\Microsoft\Windows\Credentia lsDelegation\AllowDefaultCredentials
 Name: 1
 Type: REG_SZ
 Data: TERMSRV/my-rds-server-01

 This contains the list of your rds servers. If you have more than one you need to add them all or just use TERMSRV/*

 If your RDS servers require NTLM authentication, you will need to make the following registry settings as well:

Path: HKLM\SOFTWARE\Policies\Microsoft\Windows\Credentia lsDelegation\AllowDefCredentialsWhenNTLMOnly
 Name: 1
 Type: REG_SZ
 Data: TERMSRV/my-rds-srver-01

 Again, this contains the list of your rds servers. If you have more than one you need to add them all or just use TERMSRV/*
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.