Mail from Ubuntu Mail to Exchange 2013

We have an in-house Ubuntu server (hosting a Drupal-based intranet site) and in-house Exchange 2013 server.  The Ubuntu server has postfix installed and can successfully email external addresses (e.g. my gmail account).  Messages directed to the in-house Exchange server however seem to black hole (no record in the message logs).

I have a custom receive connector that allows for basic authentication from specified IP addresses within the domain (Basic authentication only; allowed from all permission groups).  Other servers in the list are able to send mail successfully.

Any recommendations on what I might be missing here?  Thank you very much in advance.
Dan CarpIT DirectorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:
Configure your exchange receive connector to accept messages from Linux and don't require authentication.  Configure your Linux SMTP to forward messages for your domain to the IP address of your receive connector.
Dan CarpIT DirectorAuthor Commented:
Thanks Mohammed.  I've created a new receive connector on Exchange with the following parameters:

Authentication: (none selected)
Permission groups: (all selected)

Remote network settings: (IP address of Ubuntu server)
Network adapter bindings: (All available IPv4)
FQDN: exchangeserver.domain.com

On the Ubuntu side, I've got Postfix installed.  To confirm that everything is correct, I've reconfigured my installation using the command:
sudo dpkg-reconfigure postfix

Open in new window

Then used the following values during postfix configuration:
Internet Site
ubuntuservername.domain.com
admin
ubuntuservername.domain.com, localhost.localdomain, localhost
No
127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 192.168.0.0/24
0
+
all

Is there some location in the settings that I need to specify the name of my Exchange server?  If I run the command:
host mail.domain.com

Open in new window

It does return (correctly pointing to the Exchange server IP address):
mail.domain.com has address 192.168.0.20

Open in new window


Thanks!
Mohammed KhawajaManager - Infrastructure:  Information TechnologyCommented:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Dan CarpIT DirectorAuthor Commented:
Thanks very much again Mohammed.  The key that I pulled from that URL was the following:

Routing all mails to a smarthost :
These instructions assume the postfixconfig files live in /etc/postfix/main.cf
In /etc/postfix/main.cf add the line:
relayhost = mxpool1.spamgateway.comodo.com:587

Based on that info and what I pulled from this URL (http://www.postfix.org/BASIC_CONFIGURATION_README.html), I changed the following line to:
relayhost = [exchangeserver.domain.com]

Open in new window

After restarting postfix (with the command "postfix reload"), mail is now flowing successfully through my Exchange server.  Again, thanks very kindly!
Dan CarpIT DirectorAuthor Commented:
Provided additional information and useful link.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.