Removing Hub Transport Role from Exchange 2010 Server not working

Greetings,

My environment has 2 Exchange 2010 servers.  One is the server that hosts all production mailboxes, OABs, OWA, and public folders, while the other server is only to be used as an Archive server (hosting archive mailboxes).  Upon implementation of the Archive server, we ran into a problem as all outgoing email started routing through that server.  As this server had no rules, nor AV protection at the time, this was a bad scenario.  My understanding is that this was as designed, as Exchange will user the Exchange Server with the Hub Transport Role and the most resources available.  So, I quickly made a send connector that went from the Archive server back to my primary Exchange server and then out to the Internet.  Emails were once again flowing.  Anyhow, this is obviously not an ideal situation.  So, I'm looking to remove the Hub Transport Role from the Archive server, forcing all email to go out the primary Exchange server.

In initial attempts to use the SP3 setup.exe (and Control Panel) to remove the HT role, there was no option to uncheck the HT box.  I then used the command setup.com /Mode:uninstall /Role:HT.  That appeared to be successful.  Upon trying to run the uninstall via the SP3 setup.exe or Control Panel, it showed that the HT box was greyed out, but clear.  However, within the EMC and EMS (get-exchangeserver), it still states that the Archive server has the Hub Transport role.

Any ideas what is going on?

I appreciate any assistance.

Thank you,

Jeremy
LVL 3
JerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
Run this command and post the result.
Test-servicehealth
0
JerAuthor Commented:
Role                    : Mailbox Server Role
RequiredServicesRunning : True
ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeIS, MSExchangeMailboxAssistants, MSExchangeMailSubmission, MSExchangeRepl, MSExchangeRPC, MSExchangeSA, MSExchangeSearch, MSExchangeServiceHost, MSExchangeThrottling, MSExchangeTransportLogSearch, W3Svc, WinRM}
ServicesNotRunning      : {}

Role                    : Client Access Server Role
RequiredServicesRunning : True
ServicesRunning         : {IISAdmin, MSExchangeAB, MSExchangeADTopology, MSExchangeFBA, MSExchangeFDS, MSExchangeMailboxReplication, MSExchangeProtectedServiceHost, MSExchangeRPC, MSExchangeServiceHost, W3Svc, WinRM}
ServicesNotRunning      : {}

Role                    : Hub Transport Server Role
RequiredServicesRunning : True
ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeEdgeSync, MSExchangeServiceHost, MSExchangeTransport, MSExchangeTransportLogSearch, W3Svc, WinRM}
ServicesNotRunning      : {}
0
Zacharia KurianAdministrator- Data Center & NetworkCommented:
So, I quickly made a send connector that went from the Archive server back to my primary Exchange server and then out to the Internet

1. Make sure there are not items in "queue"

2. Migrate any custom "Receive Connectors"  in  your "Archive Server" and then remove them.

Once these are done try removing the Role.

Zac.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

JerAuthor Commented:
Good thought on the queue, but this is a test environment, so there is little email activity.  This will certainly be a concern in production.

I don't have any custom receive connectors, just the Client and Default.  They look to have all the default settings.  I did remove the Send Connector that referred to the Archive server previously.
0
imkotteesSenior Messaging EngineerCommented:
Hi,

you can set submission override list so that mails will not flow through that server.

http://blankmanblog.com/general-news/tips-tricks/restricting-hub-transport-server-selection-using-submissionserveroverridelist/
0
JerAuthor Commented:
Not neglected or abandoned.  Just have had other fires pop up.  Looking into it again this week.

Jeremy
0
JerAuthor Commented:
Added another appliance to my email environment, so this is even more of a potential issue.  Will try to emulate in my test environment.
0
JerAuthor Commented:
Just ended up leaving the role and am now allowing it to send to the Internet.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.