Cannot install HP CM1312nfi MFP software or run cleaner utility

Running Windows 8.1 home 64bit.  I've previously been able to install the software for my networked HP CM1312nfi printer and scanner and use the scanning software, but want to add OCR.  I installed ReadIris Pro for OCR (which came with the printer), but got the message there was no Twain driver, so I uninstalled the HP software to see if reinstalling might add the Twain.

Now I can't reinstall it.  I've been able to get the scanner to work using HPScan and Capture (a separate Windows app), and have installed the printer using Windows Add a Printer.  But when trying to install the HP software, which hopefully includes the Twain driver, the installer starts, asks if I want to install a USB or network printer, and then just shuts down when I select 'network'.  There are no error messages, it just disappears.  On checking Task Manager it is still running as a background process.

I've tried re-downloading the software, taking care to select Windows 8.1 for 64 bit, and restarted many times.  Tried installing in Safe mode - same issue.  I've tried running the cleanup utility (scrubber.exe) that comes with the software but this also doesn't seem to work, and doesn't even appear in Taskmanager.  I've run sfc /scannow which has fixed some files, but left some files unfixed.  Not sure if this is related or not, though everything else seems to be running ok.

Any suggestions or help much appreciated in getting the installer to run.  failing that, how to install a Twain driver?  I'd like to avoid reinstalling windows as I don't want to lose an entire weekend!   I wouldn't say I'm that PC savvy so instructions in plain English please. ;-)
colin_thamesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Davis McCarnOwnerCommented:
That is a fairly old product (2008); but, are you using the latest download or the original CD?
https://h20565.www2.hp.com/hpsc/swd/public/detail?sp4ts.oid=3562007&swItemId=tw_77243_2&swEnvOid=4132#tab1
And, do you have another app installed which supports TWAIN? ( MS Word, etc.)
0
colin_thamesAuthor Commented:
Hi, yes I'm using the HP 5.1 version of the software.  It's installed in Windows 8.1 fine previously.

I do have Office 2010 that supports scanning.  That also says it can't see a scanner and that I may need to install Twain drivers.
0
Davis McCarnOwnerCommented:
Do you have a C:\Windows\Twain32 folder and what are its contents?

TWAIN is a very old standard (1992) which has historically been defined in WIN.INI and is most often a 16 bit interface which is not supported in 64 bit Windows so it may be very difficult to solve......
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

colin_thamesAuthor Commented:
Yes, I've got the folder.  It has two files:
wiatwain.ds  (not sure what this is from)
vuescan.ds  (this is from a scanning programme calling Vuescan that I trialled.  It does work but is expensive and doesn't offer OCR.)
0
Davis McCarnOwnerCommented:
There needs to be a folder inside of the TWAIN32 folder named for the scanner model (may be somewhat cryptic) and a something.DS within it.  Do they exist?
0
colin_thamesAuthor Commented:
Nope, nothing else there.  I guess if I could get the installation programme to run it might be.
0
Davis McCarnOwnerCommented:
Have you tried right-clicking on the installer and choosing Run As Administrator?
And please don't tell me you have UAC turned off!
0
nobusCommented:
did you install windows 8.1 fresh?
if that is so - you may have hardware problems
try the printer on another pc
0
colin_thamesAuthor Commented:
Yes, I've tried running it as Administrator.  I've also tried running it under compatibility for Win 7 and Vista Service pack 2.

The 8.1 installation is an upgrade from 8 which came with the laptop.  UAC is turned on.

The problem seems to be that the installer won't run, although it launches, as soon as I select the type of connection I have it just sits in the background in Task Manager.  

Other installers seem to run OK.
0
Davis McCarnOwnerCommented:
Ok, what antivirus/firewall software are you running and is the Windows firewall in its default state?
0
nobusCommented:
as  said, i suspect  hardware problems - test ram and disk to be sure about the basics
i use the uBCD for this
Hardware diagnostic CD    UBCD

go to the download page, scroll down to the mirror section, and  click on a mirror to start the download
Download the UBCD and make the cd   <<==on a WORKING PC, and boot the problem PC from it
Here 2 links, one to the general site, and a direct link to the download

since the downloaded file is an ISO file, eg ubcd527.iso - so you need to use an ISO burning tool
if you don't have that software, install cdburnerXP : http://cdburnerxp.se/

If you want also the Ram tested - run memtest86+ at least 1 full pass,  - you should have NO errors!
 
For disk Diagnostics run the disk diag for your disk brand (eg seagate diag for seagate drive)  from the HDD section -  long or advanced diag !  (runs at least for30 minutes)

http://www.ultimatebootcd.com/                        ultimate boot cd
http://www.ultimatebootcd.com/download.html             download page

**  you can make a bootable cd - or bootable usb stick

for completeness -here's how i handle disk problems : http://www.experts-exchange.com/Storage/Hard_Drives/A_3000-The-bad-hard-disk-problem.html

**also - did you test the printer on another system ?
0
colin_thamesAuthor Commented:
DavisMcCarn, I'm running Avast! Free and Windows Firewall in normal state.  However, I've tried installing with both switched off.  Still the same issue - installation progresses to first step and then fails to launch next installer.

nobus - why do you suspect hardware issues?  The printer is running fine on my computer and an identical one (identical hardware and using a disk cloned from my laptop a while back).  The scanner runs fine on the other laptop.
0
colin_thamesAuthor Commented:
Hmm, that got me thinking.  On the other machine there are also no Twain drivers except for wiatwain.ds but it works fine for scanning, so the HP scanning software can't be using Twain.

Just makes me wonder if there's someway of cleaning out the old HP software from my machine so the installer might work?

My worst case scenario is to clone the hard disk of the second machine and put it into mine.  Not something that fills me with pleasure.
0
nobusCommented:
>>  nobus - why do you suspect hardware issues?  << Colin, i do not suspect, i only try to eliminate possible causes; so if it's running fine on others - no problem there, 1 scratched

maybe some OS files are corrupted?
try running sfc or a repair :
http://www.sevenforums.com/tutorials/3413-repair-install.html            REPAIR
http://www.sevenforums.com/tutorials/1538-sfc-scannow-command-system-file-checker.html         SFC
0
colin_thamesAuthor Commented:
Thanks nobus, as mentioned in my first post, I have run sfc /scannow but will take a look at the repair install process.
0
Davis McCarnOwnerCommented:
WIA (Windows Image Acquisition) is the successor to TWAIN and WIATWAIN.DS is the file used as the go between.  It is also part of Windows; but, is probably installed by the HP software.
From a lengthy HP forum about Windows 8.1 installation problems:
1) Make sure the installer is not running!
2) Find and delete C:\Windows\HPWINS*.DAT and HPOINS*.DAT
3) Reboot
4 Try the install again.
The files are used by the installer and it is apparently easy to have wrong or corrupted versions.
http://h30434.www3.hp.com/t5/Printer-All-in-One-Install-Setup/installer-setup-hangs-under-Windows-8-1/td-p/3042247/page/7
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nobusCommented:
in some cases - you need to run sfc twice
0
colin_thamesAuthor Commented:
Davis
Well done, your tip worked, in combination with running the software from the Administrator Account.  I only discovered this because I thought I'd try running the installer from the old CD.  It ran but kept stopping and asking me to run with Admin rights, the new installer didn't run on my normal account, even though it's set with Admin rights.  Setting the files to 'Run as Admin' didn't work so I set up my Admin Account - http://www.eightforums.com/tutorials/9650-built-administrator-account-enable-disable-windows-8-a.html 

Then I tried the new software and it ran.  Not sure if it was down to this or removing those files (the ones I found in the Windows folder had similar but not the same names  (hppins11.dat and hppins11.dat.temp and hppmdl11.dat.temp)

Either way problem solved, and Readiris works with my scanner now.

Many thanks.
0
colin_thamesAuthor Commented:
Worked when installing from Admin Account but not an account with Admin privileges.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Installation

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.