Filemaker Server 14 - Webdirect NAT access

Hi there,

I am able to access Webdirect locally but not from the Internet.

Port 80 is forwarded to my server.

Access Restriction is disabled.

Same problem when firewall is disabled.

Thanks for your help,
Rene
LVL 10
ReneGeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will LovingPresidentCommented:
Are you testing access from completely outside your LAN or are you by any chance trying to access WebDirect by entering the external IP address from inside the LAN? If you're working within the LAN but testing by putting in the external IP address, try it from completely outside the LAN.

Some internet providers, notable Comcast but also others, block internal references like that, meaning you inside the LAN, specifying the external IP address in a browser, expecting it to go OUT and then return to your router and be forwarded to your FM Server.

I had this same issue until I tried connecting via my phone and another computer on another network. Both showed that WebDirect was working properly, just not from within the LAN using the external IP.
0
ReneGeAuthor Commented:
Hi Will,

Thanks for your prompt reply :)

Filemaker Server 14 is hosted on my server at home.

From inside the LAN, I am able to access Webdirect by using localhost.

From the Internet, I put my home wan IP address, and port forward port 80 to my home server.

By the way, I am able to RDP my server from the Internet without a problem; which I forwarded port 3389.

Thanks
0
Will LovingPresidentCommented:
From the Internet, I put my home wan IP address, and port forward port 80 to my home server.

The question is are you trying to put in your home WAN IP address from within the LAN (and behind the router) or from outside. If you want to go to my profile and then message me directly with the IP address, I can check it from outside.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

ReneGeAuthor Commented:
From outside
0
Will LovingPresidentCommented:
OK, so something is not working properly with the forwarding. Do you get anything at all or just a 404 page not found?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ReneGeAuthor Commented:
Hi Will,

Found the stupid problem

Windows firewall turned on by itself.

I never use Windows firewall as my firewall.  So that's why I did not think looking at it :)

Thanks Will for you help :)

Cheers,
Rene
0
ReneGeAuthor Commented:
Thanks :)
0
Will LovingPresidentCommented:
You're welcome. You can leave Windows Firewall on, just be sure to create exceptions for FileMaker Server as an app/process and for Ports 80, 5003 and any other FM Ports that you might be using.

http://help.filemaker.com/app/answers/detail/a_id/14402/
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
FileMaker Pro

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.