WordPress Images disappeared. Can't upload new ones

Hello. I recently updated my WordPress template.   After the update I had several problems from permalinks working etc.  The problem I have now is that a lot of my images are not showing up.  When I go to media library the images aren't showing up. Only the icon for an image is there but no image.  When I click on edit to edit the image it isn't there. Only the icon for an image.  If I go to the permalink or short link to see the image in my browser then I get the 404 - File or directory not found error. But when I go to the directory in the link the image file is there and I can open it using another application like Photoshop.  So I know the image is there, and WordPress knows the location, and it is less than 2mb.  But I cannot get it to display in the image gallery or on the site.  I can even delete the image and re upload it and I get the same result.
cdlcidditAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ankit PareekOnline MarketingCommented:
Hi Cdlciddit,

You can do the following steps it will be work for you.
You first switch to classic default theme
Remove your current featured theme and now check that on default theme all things are working properly.
then again search your theme and apply all changes again
If this process is not worked then first back up your all content, images to local
Login to host account and reinstall wordpress version again now restore your data

It will be work for you. Can you more specify that which host you are using to host your website. all posts URl if shows not found 404 error or you are unable to change permalink structure also then need to be contact from hosting provider i am also faced similar problem few days ago and they solved on their end
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jason C. LevineNo oneCommented:
The problem I have now is that a lot of my images are not showing up

So some are? Is there any rhyme or reason to images that show up vs. images that don't?
1
Lucas BishopClick TrackerCommented:
Could this be a permissions issue with the /wp-content/uploads directory? Make sure this folder and its sub-folders are set to 0755 permission.
1
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

cdlcidditAuthor Commented:
Hello. Thanks for all the responses.  @Ankit Pareek and @Jason C Levine and @Lucal Bishop Yes. It is very weird.  All my images are in the same folder.  I uploaded all them using the WP image uploader.  But some of them show up and some don't.  That's why I don't get it.  After using the Chrome inspector I saw that it was giving rewrite errors on some of the images.  This is probably because in order for WordPress permalinks to work on a windows server you have to install a URL Rewrite module in IIS and add some code to your web.config file.   So I basically had to delete the whole WordPress and MySql install and start fresh.  I'm in the process of trying to import my data files and database tables now.
0
Jason C. LevineNo oneCommented:
So I basically had to delete the whole WordPress and MySql install and start fresh.

Well deleting your DB will certainly remove the images from the library but it should remove ALL of them, not just some.
1
cdlcidditAuthor Commented:
@Jason C. Levine.  Yes. I did delete them. But I did a restore of my old database and that fixed the problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
WordPress

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.